Support » Plugin: MailPoet - emails and newsletters in WordPress » Emptying the Trash not Working

  • Resolved pouicpouic

    (@pouicpouic)


    Hello,
    The MailPoet trash doesn’t empty, although the subscriber I need to delete are NOT either in WordPress Users list or the WooCommerce Customers list.
    How to solve this and prevent it to happen again?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Same issue on my side. I removed both the users in wordpress and deleted the orders in woocommerce but I’m still not able to empty the trash.

    Plugin Support dromero20

    (@dromero20)

    Hi!

    If you can’t delete the users, they still have to be added to your site as Users. Please ensure that they’re not added in WordPress dashboard > Users page.

    If it’s a WooCommerce user, you also need to delete any order they might have on your site. After that, you can clear your site’s cache and try to empty the trash again.

    If that doesn’t work, you could delete the user from the wp_mailpoet_subscribers table in the database, though I’d recommend checking first what I mentioned before.

    Thread Starter pouicpouic

    (@pouicpouic)

    Thank you for your reply.
    As I mentioned before, the remaining subscribers are found nowhere else than in the MailPoet list.
    I can of course delete subscribers in the database to empty the trash,
    but the problem persists when the trash fills up again.
    So this is not the solution I am looking for.
    There should be a faster way to empty the recycle bin without having to crawl the database every time you want to delete a subscriber?

    Plugin Support Elvira K. a11n

    (@treibalen)

    Hi there @pouicpouic,

    I’m sorry to hear that you’re still seeing issues with deleting subscribers.

    Can you please clarify what happens exactly when you click Empty Trash? Do you receive any error messages?

    Can you please share a screenshot of your Trash when it happens?

    Thread Starter pouicpouic

    (@pouicpouic)

    Hello Elvira,
    Thank you for your answer.
    I have tried to reproduce the problem on my client’s website in order to take some screenshots but MailPoet seems to work.
    I didn’t have any problem to empty the trash after creating new users.
    So I will mark this topic as solved, sorry for this false alarm.
    If my client has trouble again emptying the trash I will clean the database manually like I have done before.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Emptying the Trash not Working’ is closed to new replies.