WordPress.org

Support

Support » Plugins and Hacks » WooCommerce SagePay Direct Payment Gateway » Empty WooCommerce error when using SagePay

Empty WooCommerce error when using SagePay

  • Hi

    I’ve recently installed SagePay Direct but running into a strange problem. When clicking Place Order, with SagePay selected as the payment method, I get the spinning loader gif then the page scrolls to the top and I get a WooCommerce error message, but with no error.

    <ul class="woocommerce_error">
    			<li></li>
    	</ul>

    When using PayPal or Bank Transfer the payment goes through fine. I realise this may be just as much a WooCommerce problem as much as a SagePay Direct problem but just wondering if you had any ideas what it could be?

    Thanks,
    Dan

    http://wordpress.org/plugins/sagepay-direct-for-woocommerce-payment-gateway/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author swicks

    @swicks

    Hi

    I would expect this plugin to return ‘ – unknown error’, if it didn’t know how to handle the error. To get an empty
    <li> something would have call woocommerce->add_error() with no content.

    What version of SagePay Direct are you running and what version of WooCommerce?

    Have you tried running in debug – did it return any information?
    Take a look for any transactions in SagePay VSP?

    thanks

    Steve

    Hi

    SagePay Direct version is 0.1.6.8 and WooCommerce version is 1.6.6.

    I’ve tried Debug on and not getting anything through that either.

    Not sure what else to look at!

    Thanks
    Dan

    Actually, there was one error that showed in debug.log, but I can’t be certain if it’s related or not.

    [04-Feb-2014 16:34:19] PHP Notice: loop-shop.php is deprecated since version 1.6 with no alternative available. in /web2/user40039/website/wp-includes/functions.php on line 2957

    Plugin Author swicks

    @swicks

    Hi
    I’ve just created a brand new virtual host and installed WordPress 3.5 using WooCommerce 1.6.6 with the latest sagepay direct plugin 0.1.6.8 and it worked fine in ‘test’ I was able to take orders and use 3d secure.

    I would look at other installed plugins or your environment effecting this.

    Steve

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Empty WooCommerce error when using SagePay’ is closed to new replies.
Skip to toolbar