WordPress.org

Support

Support » Plugins and Hacks » Empty trash doesn't work

Empty trash doesn't work

  • Greybox
    Participant

    @greybox

    Empty trash button doesn’t work for me – the files are still listed after I tried to click Empty Trash, Delete with and without checking the files. Even manually deleting files from /uploads/wpmc-trash/ and scanning again didn’t help. I had to reset the WP Media Cleaner table and rescan again.

    As a side note, I don’t think Delete button should appear on the Trash tab – deleting individual files should place them into trash folder, but they are already in the trash folder! I would rather restore Scan button in that location.

    http://wordpress.org/plugins/wp-media-cleaner/

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author Jordy Meow
    Participant

    @tigroumeow

    Mmm, I tried again and again but cannot replicate. The Empty Trash button works perfectly for me. Did you try on a clean install of WordPress? If you have a way I could replicate that would be awesome.

    Yes, deleting the files manually wouldn’t help neither and simply breaks the relationship between the physical trashed file and the database entry.

    The delete button in the trash folder actually delete them “completely”. It’s an alternative to emptying the folder. For some reason there could be a few huge files the user want to delete but he prefers to keep the others little files to make sure they are not used anywhere.

    Greybox
    Participant

    @greybox

    Sorry, I can’t do a clean install – it’s a production site. I will try on my other production site to see if there is any difference.

    In my case pressing delete button doesn’t do anything. What is the difference between Delete in the trash tab and Empty Trash?

    Plugin Author Jordy Meow
    Participant

    @tigroumeow

    Empty Trash means Delete “ALL”. It would be weird if one was working and the other not. The problem is definitely the same for both of them, but I have no idea what it is…

    I have the same issue, delete trash didn’t work.I did manually remove items from trash folder. Message Issue: Media (DB entry) not found. this is a production site..how do delete files??
    Thanks

    Greybox
    Participant

    @greybox

    videoink: as a workaround you can press Reset and then rescan after you manually delete the files via FTP.

    I checked on my other site – same problem.

    I don’t know if it’s related or a separate problem – thumbs are broken in Trash tab (you may need to refresh (F5) to reveal that). The Trash tab page loads very slow as if it is looking for the thumb image but can’t find it.

    And a little cosmetic issue: the Trash tab is not separated by “|” character from the Ignored tab.

    Plugin Author Jordy Meow
    Participant

    @tigroumeow

    Weird, I am testing the trash but it works on all my websites. Don’t you have any errors in your PHP logs? Something is happening somewhere.

    It’s a separate issue: there is indeed a bug with the thumbs in the trash tab. They are trying to access the images from their previous path… This will be fixed in the next version!

    Oh, about the ‘|’ it’s normal 😉 Just separate the search from the rest.

    Greybox
    Participant

    @greybox

    Where can I find the PHP logs? I could not find anything within WordPress interface. In my service provider PHP manager there is only an option to switch between PHP 4 and PHP 5 and it is currently set to PHP 5. Maybe you can suggest some temporary debugging modification code to find out what is going on?

    As for the last issue: I am not sure what “search” you are talking about. Let me clarify again what I mean. There are three tabs: Issues, Ignored and Trash, correct? And this is how I see the “tabs” now:

    Issues(20) | Ignored(0) Trash(4)

    As you can see, Trash is not separated from Ignored. I think they should look like this:

    Issues(20) | Ignored(0) | Trash(4)

    Greybox
    Participant

    @greybox

    There is also a minor question about the file size formatting/representation. For example, my screen shows “816.97 KO” for a particular file, but I know this file is 816,971 byte or 797 KB, and I am not sure what “O” means.

    Plugin Author Jordy Meow
    Participant

    @tigroumeow

    Sorry… “KO” is actually in French only. I will change it to “KB”. O means octets 🙂 Will be corrected in the next release.

    For the logs, you might have to ask your hosting provider. That’s strange they don’t let you see those. Aren’t they somewhere available through FTP?

    Oh, sorry, you meant that! Indeed, a ‘|’ is missing! Thanks for seeing that.

    Greybox
    Participant

    @greybox

    And what about the decimal point?

    I could not find any relevant log via FTP. Is there any other way to debug? Like I suggested, some debugging mod? I was thinking about the access rights, but this is a little odd that that you can move the files but can’t delete them with your script.

    Greybox
    Participant

    @greybox

    May I also suggest to move the Flattr logo to the bottom of the page where you have the PayPal logo. This is only because Flattr logo is close to the actively used buttons, hovering the cursor above it by accident causes the mini-window to appear and it is a little bit annoying to manually close it or wait for a few seconds for it to disappear automatically.

    [ Please do not bump, that’s not permitted here. ]

    Plugin Author Jordy Meow
    Participant

    @tigroumeow

    Sorry I have been really busy and unfortunately… I am still 🙁

    I wouldn’t worry too much about the Flattr, I used it on all my plugins
    and I don’t really want to try to move it yet; also I think they will correct this “hovering” issue or might add option to remove it (if I can, I will definitely will).

    For the debugging, there is no other way, by far the best is the PHP logs since there must be something there and it would point to the exact issue.

    Decimal points should be from the dot to a comma, right?

    Greybox
    Participant

    @greybox

    Plugin Author Jordy Meow
    Participant

    @tigroumeow

    It’s very possible 🙂

    In the file ‘wp-media-cleaner.php’ can you try to change the code in the function ‘function wpmc_activate’?

    The lines 827 and 830 should be:

    size INT(9) NULL,
    ignored BIT NOT NULL DEFAULT 0,
    deleted BIT NOT NULL DEFAULT 0,
    issue TINYTEXT NOT NULL,

    Then use the Reset button in the plugin dashboard and… try again 🙂 Tell me if it works better for you.

    Greybox
    Participant

    @greybox

    Didn’t help, sorry.

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Empty trash doesn't work’ is closed to new replies.