Support » Plugin: Yoast SEO » Empty Sitemap

  • Resolved Kammi

    (@thehappykamper)


    Hi there,

    I’m having some trouble with a blank sitemap and was hoping someone could point me in the right direction please! The link is http://thehappykamper.com/sitemap_index.xml but the page appears blank (as does the source).

    Google Search Console gives me the error: Your Sitemap does not contain any URLs. Please validate and resubmit your Sitemap.

    I’m using the latest version of the Yoast SEO Plugin.

    From reading around, I’ve tried:
    – clearing the cache
    – resubmitting my sitemap to google console
    – disabling a security plug in
    but none of these things helped – no change.

    I’d appreciate any advice please!

    Thanks 🙂
    K

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • I am having the same problem and it has been happening for days. My page index is going down drastically on google console and i am worried it is going to be empty which will affect my Google search.

    I have not changed or updated anything on the website except the update i did on the plugin itself.

    If yoast could help with this error before it causes more damage..

    Plugin Support MariusG

    (@marius_codeinwp)

    Hi Kammi,

    Please update to Yoast SEO 7.9 and let us know if the issue persists. In addition, please also check if the XML Sitemap feature is enabled in SEO → General → Features.

    We ask as the sitemap should’ve been able to load at this URL too: http://thehappykamper.com/?sitemap=1 (the result should’ve been the same as http://thehappykamper.com/sitemap_index.xml)

    We are looking forward to hearing from you.

    Same issue here. Anyone figure out to resolve?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Empty Sitemap’ is closed to new replies.