Support » Plugin: WooCommerce » empty shop page

  • Resolved mrloco

    (@mrloco)


    Hi!

    After changing the default language of my site – my shop page is empty.

    The link to the page i shared with you is my test site.

    So the problem is, that ENG was my default language. EE and RUS languages wasn’t default.
    I changed the default language and now the default language is EE. After that, my shop page is empty on EE and RUS languages and products are only on ENG shop page.

    If i go to the woocommerce settings and update them – shop page in all languages are working!

    But if i do some changes in the dashboard, for example, save/update permalinks – the shop page in EE and RUS empty again.

    If i change the default language to ENG back – all works well.

    It seems that that woocommerce not updated with the new default language and the empty shop page because of that.

    Any ideas?

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support maykato

    (@maykato)

    Hello,

    It sounds like the issue is related to the multilingual plugin you are using. We’d recommend reaching out to the plugin developer for further assistance.

    Thread Starter mrloco

    (@mrloco)

    I talk to them(WPML) for a week or maybe two, but nothing. I thought, maybe woocommerce may have some settings or maybe reinstall woocommerce?

    Thread Starter mrloco

    (@mrloco)

    It seems that it is all about custom product base permalink /shop/%product_cat%/. After default language changing something went wrong… But what? 😀

    Plugin Support AW a11n

    (@slash1andy)

    Automattic Happiness Engineer

    Hey again!

    We don’t have any kind of insight into how wpml would handle changing of default languages, because all of the functionality of changing languages are added by wpml.

    They would be the best, and only, place for more insight into what’s going on with the site here.

    I’m going to mark this resolved on our end, and I hope the wpml team gets back to you soon with a solution!

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.