Support » Plugin: GN Publisher: Google News Compatible RSS Feeds » “Empty sections” issue

  • Hi Chris,

    we can’t get into google news because of the “empty section” error they throw at us all the time.

    We do use cloudflare but have removed all restrictions and country blocks. Also we checked that we do not lock out the feedfetcher bot. Still no improvement.

    So we are really running out of ideas what to do, to make this work,.

    Could you have a look, please?

    Here is the link to our feed:
    https://www.news64.net/category/news/feed/gn

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Chris Andrews

    (@christopheran)

    Hi Sebastian,

    Can you double check and make sure that, in the Publisher Center, under the ‘content’ tab, the sections are set up as ‘feed’, then ‘generate article from feed’?

    If that’s ok, be sure to ‘refresh’ the page using your browser’s refresh button, about ten minutes after you’ve entered the sections and save them, then recheck to see if the sections are populated by articles.

    Also check under the ‘review and publish’ tab, are there any issues other than ’empty sections’, or is that it?

    The feed itself looks ok, I don’t see any problems there,

    Chris

    Thread Starter sebastianlm

    (@sebastianlm)

    Hi Chris,

    have done all that.
    I noticed that it sometimes took hours that the Publisher Center found articles, but finally they got there. Sometimes it seemed that they vanished again (when I checked a day later or so). But there were no outages of the server or so. I am really out of ideas 🙁

    No other issues there. (At first we had some more issues because of blocked countries but we got that solved).

    Best
    Sebastian

    Plugin Author Chris Andrews

    (@christopheran)

    If you would please, do a test by having a section just called ‘latest’ or something like that, and let’s put in your main feed as the url for that section: https://www.news64.net/feed/gn/ and test that to see if it loads up articles (do give it about ten minutes after you save the changes, then refresh the page using your browser’s refresh button).

    I’m wondering about that because in testing, that feed responds quickly:

    https://tools.pingdom.com/#5cc06843c4800000

    whereas if I use a category feed, like https://www.news64.net/category/news/feed/gn/ I get a really slow response for some reason, like 17 to 22 seconds. I’m wondering if the feedfetcher bot is just timing out when it takes that long:

    https://tools.pingdom.com/#5cc0657b5b400000

    I don’t know what would be causing the category feeds to be that slow though…

    Thread Starter sebastianlm

    (@sebastianlm)

    I did the test as you requested.
    After 18 minutes no articles are shown.
    https://ibb.co/k3pzg2P

    It seems that the feed was checked right away (4:57pm is the time when I added this section). But 18 minutes no new update time is shown. And there are no articles, too.

    I have also no idea why the feed is so slow.

    Plugin Author Chris Andrews

    (@christopheran)

    Do you have a way to check your access logs to look for any hits from useragent: feedfetcher ? That way we could tell if it’s reaching your site.

    Thread Starter sebastianlm

    (@sebastianlm)

    I have asked my admin to check the logfiles.
    I’ll let you know as soon as I know.

    Plugin Author Chris Andrews

    (@christopheran)

    Sounds good, if they can’t find it, we’ll know it’s being blocked somewhere.

    Thread Starter sebastianlm

    (@sebastianlm)

    This is what my developer told me (might not help much):
    Since the website uses cloudfront, therefore, our logfiles only contain cloudfront requests and not the original requests (e.g. from the bot).

    The feed loads pretty slow (about 9 seconds) which is probably caused by the plugin. It seems a bit unusual that the feed is not cached because of a “no-cache” command in the header. Is it possible to allow caching?

    Does this help anything?

    Plugin Author Chris Andrews

    (@christopheran)

    The nocache is to prevent the feed from being cached because it was causing delays in articles being added to the Publisher Center. I don’t have a built in way to remove it, but you are welcome to edit the /templates/google-news-feed.php file and remove the nocache coding (you’ll see it clearly documented there) if you are familiar with editing php files.

    The only problem is that you would have to do that with each update of the plugin.

    I’d rather figure out a way to get this working for you without having to do that though… I’m just not sure how to go about it though. It looks like you use both cloudflare and cloudfront. I know that cloudflare allows feedfetcher through, I’m not sure about cloudfront. I would expect it to…

    The feed is working ok and it validates. All I can think is that the crawler is being blocked somewhere.

    I would suggest contacting Google News Publisher support and ask them to take a look to see if they see any issues that might be causing a problem. If it’s something about the feed, I can definitely address that, if it’s an issue with the crawler not being about to reach the feed, then maybe contact CloudFront support to see if they can help with that.

    In an upcoming version of GN Publisher I’ll have logging in place so we can see if FeedFetcher reaches the feed. With cloudfront not passing the useragent info through though, I’m not sure it will work for cloudfront users… I’ll have to think that through,

    Chris

    Thread Starter sebastianlm

    (@sebastianlm)

    Hi Chris,

    I think we can rule out that the bot cannot access the feed. I used another feed (not from your plugin) and everything works fine. Also got accepted by the publisher center.

    This is the feed that worked:
    https://www.news64.net/category/news/feed/

    Regarding the caching:
    I get that. I think it would be great if the user of the plugin could switch caching on and off, maybe even can choose some caching intervals.

    I had issues with cloudfront and feeds. It is easily fixed. Go to your cloudfront console in AWS. Then the behaviors tab. Add a new behavior called “feed/*” (no quotes). Then change the attributes as follows:

    Allowed http methods: GET, HEAD, OPTIONS, PUT, POST, PATCH, DELETE
    Cache and origin request settings: Legacy
    Cache Based on Selected Request Headers: All
    Forward Cookies: All
    Query String Forwarding and Caching” Forward all Cache based on All

    Leave the rest alone. Then save this. Move it to the top of the list (item 0)

    This will route feed requests to your server. This solved the problem for me.

    Plugin Author Chris Andrews

    (@christopheran)

    SeattleLion,

    Thank you for this info! I’ll pass it on to others struggling with CloudFront,

    Chris

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.