Support » Plugin: WooCommerce » Empty product .CSV export file

  • Resolved SLV

    (@dwnl)


    Hello,

    I want to export some products into a .CSV file.
    But that file is empty…

    I go to: Products -> all products -> Export
    I want to export All columns
    I want to export All products
    I want to Export only the category: Test, so I select that one.
    I click on: Generate CSV
    Open it with Microsoft Excel
    And it is empty. All exports I try are 1 kB and empty.

    The only plugin that is active is: Woocommerce
    The active theme is: Twenty Twenty-Two

    I went back to WooCommerce Version 4.7.0, but this did not make a diverence.
    I do not see any errors in the error logs

    Can you help me fix this?

Viewing 15 replies - 16 through 30 (of 34 total)
  • Plugin Support Margaret S. woo-hc

    (@margaretwporg)

    Hi @dwnl

    If I rename that advanced-cache.php file it will add a new file with this name. So this is part of the wordpress itself or Woocommerce. I can not turn it off.

    Instead of turning it off, can you please have its cache purged instead?

    Let us know if that helped.

    Hi @temporaryfailure

    Thanks for posting your comment here.

    However, kindly create a new thread so that your issue can be looked at individually.

    This is in line with the forum guidelines on posting on related threads / existing threads with similar issues.

    In your thread please remember to include a copy of your site’s System Status Report.

    Cheers

    Thread Starter SLV

    (@dwnl)

    I can not cache purged instead? because it is in WordPress or woocommerce itself. There is no button to purge…

    Plugin Support Margaret S. woo-hc

    (@margaretwporg)

    Hi @dwnl

    There is no button to purge

    As we mentioned before, disabling or purging cache from that plugin needs to be done by the hosting provider, because it is a drop-in plugin.

    You can read more on this here: https://kevdees.com/what-are-wordpress-drop-in-plugins/

    I hope this helps. 🙂

    Thanks

    Thread Starter SLV

    (@dwnl)

    The hosting provider said:

    That cache is already disabled. The wp-config also indicates that wp_cache is false. I also don’t see any other caching plugins active. So they are all disabled.

    Plugin Support Igor H woo-hc

    (@ihereira)

    Hello,

    Sorry to hear that the issue persists and the file is empty, can you please provide a copy of the CSV file generated? You can share via GoogleDocs URL.

    We’ll look forward to hearing from you.

    Thread Starter SLV

    (@dwnl)

    Plugin Support André woo-hc

    (@chiape)

    Hi @dwnl

    Can you check if there’s any fatal error on your WooCommerce log?

    You can find them by navigating to WooCommerce > Status > Logs! Paste them here if you find any.

    I hope to hear from you soon!

    All the best,

    Thread Starter SLV

    (@dwnl)

    There are no errors

    Plugin Support Brad P. a11n

    (@snaacks)

    Hi @dwnl

    Thank you for providing all of the information we’ve requested and for checking for any fatal error logging.

    At this point we’ll likely need to look into this a little deeper and may need to review some information we wouldn’t ask you to post on a public forum. With that in mind please open up a support request and link to this thread to allow us to assist further.

    Thank you!

    Thread Starter SLV

    (@dwnl)

    thanks @snaacks, I opend a support request over there.

    Plugin Support Adam Heckler

    (@adamkheckler)

    Thanks! We’ll go ahead and mark this thread as Resolved then and continue working with you via email. 🙂

    jrinfograf

    (@jrinfograf)

    Same problem generating CSV and XML.

    I´ve created a variable product and observed only export variable products. Simple products in csv is empty.

    P.E: When generate xml feed for merchant, only generate variable products, no simple procucts. Reviews feed no problem generating xml.

    Is resolved this issue ?

    Thanks.

    Plugin Support Margaret S. woo-hc

    (@margaretwporg)

    Hi @jrinfograf

    Thanks for posting your comment here.

    However, kindly create a new thread so that your issue can be looked at individually.
    https://wordpress.org/support/plugin/woocommerce/#new-topic-0

    In your thread please share the details about the issue you’re facing.

    This is in line with the forum guidelines on posting on related threads / existing threads with similar issues.

    Thread Starter SLV

    (@dwnl)

    @jrinfograf No not resolved, we don’t know how to fix this.
    The solution right now is just to export simple products separately from the variable products so you get 2 .csv files.

    • This reply was modified 5 months ago by SLV.
    Sean Conklin

    (@seanconklin)

    Same trouble here. I’m contributing to this thread since it appears unresolved and many parties seem concerned about this one as CCs.

    Findings:

    I have a LocalWP copy of the site that can export product CSV just fine. I have a cloud server copy of the site hosted by Linode that will only produce the header row in the product CSV export (empty product rows). Thus, I suspect an environment incompatibility.

    Both environments are PHP 8.0 but my server runs v8.0.20 whereas LocalWP uses the base v8.0.0. Also, LocalWP is setup with Nginx whereas my cloud server runs Apache/2.4.53 (CentOS Stream) and PHP-FPM.

    If I export all ~1,000 products the site takes a minute to produce the CSV file, so I know it’s crunching the product data. If I limit it to one product category then it kicks out the empty-ish file immediately (empty-ish because it does have a header row).

    I found an interesting write-up about the possibility of network loopback or firewall causing trouble with a library embedded within WooCommerce called WC_Background_Process. Ref: https://www.informaticapressapochista.com/web/strange-case-woocommerce-csv-export-plugin-not-working/

    I do use Cloudflare Free edition in the problematic environment.

    The problematic environment does produce WP Export XML files just fine and the WP > Tools > Site Health indicates no loopback trouble. The only library that my server is missing is the optional Image Magick.

    I’m using the Twenty Twenty-Two theme and have disabled all plugins except WooCommerce.

    Here’s another thread that appears to be about the same problem: https://stackoverflow.com/questions/68831447/woocommerce-export-products-to-a-csv-file-function-produces-empty-csv-file

    I’ll reply once I have more info on this puzzler!

Viewing 15 replies - 16 through 30 (of 34 total)
  • You must be logged in to reply to this topic.