Support » Plugin: WP Stripe » Empty popup on Mac

  • Resolved scytheria


    Sorry for duplicate post, seem to have initially placed in the wrong forum.

    Set this up from a computer running Fedora. Tested in Chrome (version 21 I believe, an older version, due to compatibility issues with Linux) and it worked fine. Also worked fine in Firefox.

    However, on a Mac using Chrome version 31, and Firefox version 26 the donate page box comes up blank. (It works in Safari though.)

    I’m seeing some weird stuff in Firebug, most notably a 404 related to this:

    Anyway my client keeps insisting the donation button doesn’t “do anything” and lo and behold when working from a Mac it sure doesn’t. I’m not sure where the problem lies but I’m using the latest version of the plugin. Please let me know what I can do from my side to resolve this. Since it’s browser/OS specific I’m really hesitant to think it’s any of my other plugins, of which there are very few anyway. Additionally, I am using the Twentyeleven theme.

Viewing 1 replies (of 1 total)
  • I’ve resolved this now, couple of things if anyone else has this problem:

    WordPress HTTPS doesn’t play nice with the popup, with SSL enabled or disabled through the Stripe settings. This is unfortunate because your form doesn’t show anything indicating it’s secure. I’d rather the whole page load with https protocol and show my little padlock. Seriously, it really doesn’t look like the form is encrypted to someone who is trying to see at a glance if the site is secure.

    So, what I ended up doing was getting this alternative version of WP Stripe installed instead:

    This allows me to embed the form, which I prefer anyway, then set up the https protocol on the whole page. Much better. With a few tweaks to allow the form to display without a huge chunk of white text underneath it, it seems to be working. I’ll have to test on other OS’s but on Chrome, Firefox, and Safari on the Mac I’m working on now, I’m not having any problems.

Viewing 1 replies (of 1 total)
  • The topic ‘Empty popup on Mac’ is closed to new replies.