The Support Forums will be in read-only mode for a scheduled maintenance window on 01 September 2016 14:00 UTC - 20:00 UTC. More information.

MarketPress - WordPress eCommerce
[resolved] Empty PDFs - digital product download (9 posts)

  1. 4now
    Posted 2 years ago #

    I have a new issue.

    When clicking the emailed link to a digital product download, the browser displays the error: The file “someting.pdf” could not be opened because it is empty.

    Even digital downloads that use to work no longer do.

    The pdfs are 0 bytes in size.


  2. Hi @4now,

    Thank you for your question and sorry to hear the problem you are having.

    Are you adding correct digital product download link in "Product Download" section of the edit product screen?

    If yes then please check whether the link entered in "Product Download" section is same as the link received in email.

    Best Regards,

  3. 4now
    Posted 2 years ago #

    Hi. I'm not sure if the links are the same.



    ( I uploaded the file via FTP )


    Order Information:
    Wisdoms Way Guide Book: 1 * 0.01 = 0.01 CAD
    Download: http://shirleylynnmartin.com/store/products/wisdoms-way-guide-book?orderid=40116c0c239a

  4. David
    WPMU DEV Support Staff
    Posted 2 years ago #

    Hi @4now,

    Hmm, did you have the Premium version of MarketPress installed previously? As I recall, digital products are not available in this free version, as noted here:


    I'll double check that but I think that may just be the issue. Did you perhaps overwrite the Premium with the free version?


  5. 4now
    Posted 2 years ago #

    only ever had the lite version.

    the first digital download product worked for months.

    the new digital product did not.
    then when I checked the first product again it was no longer working.

    I'm not sure there had been a Marketpress lite update, but I may have updated wordpress once

  6. Hi @4now,

    the first digital download product worked for months.

    the new digital product did not.
    then when I checked the first product again it was no longer working.

    It seems this is happening due to some changes you have made recently which is not compatible with this plugin.

    Have you installed recently any plugin or changed the theme?

    Have you updated any plugin / theme or WordPress since last time it was working?

    Kind Regards,

  7. 4now
    Posted 2 years ago #

    Thank you

    It was a plugin causing the issue. Although I'm not sure which one yet.

    I disabled all plugins and reactivated them in groups. Everything is working okay at the moment.

    If I ever discover the exact plugin I'll let you know, but unfortunately I don't have time at the moment.

    Thanks again!

  8. Hi @4now,

    Thank you for your reply.

    Just want to let you know, you can find out the exact plugin which is causing this issue by following the instructions provided on the flowchart displayed on the below page.



  9. WPMU DEV - Your WordPress Team
    WPMU DEV Support Staff
    Plugin Author

    Posted 2 years ago #

    Hey there.

    We haven't heard from you in awhile, so I just wanted to check in to make sure all was good.

    This thread was marked resolved, but please, if you still need help then just respond and open it back up. We can then take it from there. :)

    Hope you have a fantastic day!

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • MarketPress - WordPress eCommerce
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic