WordPress.org

Forums

Aesop Story Engine
[resolved] Empty page (5 posts)

  1. FoxTrails
    Member
    Posted 11 months ago #

    Hi there,

    when activating the aesap-plugin and trying to add a new gallery/post, the page won't load and a blank page is shown.

    I'm using the bucket theme by pixelgrade and i would love to use your plugin. Do you have any idea how i could get this working?

    Kind regards,

    Jörn

    https://wordpress.org/plugins/aesop-story-engine/

  2. simple_mama
    Member
    Posted 11 months ago #

    Hi Jörn.

    The blank/white page is due to a PHP error of some kind.

    If you are familiar with your wp-config and how to turn on debug, you can do that. Or if you're comfortable with it, read more at http://codex.wordpress.org/Debugging_in_WordPress

    An alternative is to install a plugin which can email a error log to you, like this one http://wordpress.org/plugins/error-log-monitor/

    Once we know the PHP error, we'll be able to assist you further.

    Thanks!

  3. FoxTrails
    Member
    Posted 11 months ago #

    Hi simple_mama,

    thanks for your help! Here comes the log:

    May 09, 09:32:55 PHP Fatal error: Class name must be a valid object or a string in /home1/foxtrai1/public_html/wp-content/plugins/aesop-story-engine/admin/includes/custom-meta-boxes/class.cmb-meta-box.php on line 82

    May 09, 09:33:00 PHP Fatal error: Class name must be a valid object or a string in /home1/foxtrai1/public_html/wp-content/plugins/aesop-story-engine/admin/includes/custom-meta-boxes/class.cmb-meta-box.php on line 82

    May 09, 09:33:08 PHP Fatal error: Class name must be a valid object or a string in /home1/foxtrai1/public_html/wp-content/plugins/aesop-story-engine/admin/includes/custom-meta-boxes/class.cmb-meta-box.php on line 82

    May 09, 09:33:13 PHP Fatal error: Class name must be a valid object or a string in /home1/foxtrai1/public_html/wp-content/plugins/aesop-story-engine/admin/includes/custom-meta-boxes/class.cmb-meta-box.php on line 82

    Can you make up a solution?

    Regards :)

  4. simple_mama
    Member
    Posted 11 months ago #

    Thanks for the info!

    The problem here is with the custom metaboxes used by both your theme and Aesop. Aesop and your theme are using different versions and when that happens, you get PHP errors (white screen).

    My recommendation to you is to contact your theme author as well and make them aware of this issue. If desired, you can direct him to our GitHub issue regarding this at https://github.com/bearded-avenger/aesop-core/issues/2

    Unfortunately, there isn't a work around for this at present time. You pretty much have to choose one or the other. We've only ran in to a couple themes that Aesop conflicts with and the one you use seems to be one of them. :( Sorry!

  5. Nick Haskins
    Member
    Plugin Author

    Posted 10 months ago #

    Closing this thread but please let us know if you need aything else!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.