Support » Plugin: Redis Object Cache » Empty metrics tab and more

  • Resolved alsguimaraes

    (@alsguimaraes)


    Hello, Till.

    Thanks for the plugin.
    First a question, is it compatible with Php 7.4?
    I have tried it in a cloudways setup, but nothing shows on the metrics tab.
    I have also noticed that items cached with a ttl do not seem to be cached.

    Diagnostics are:

    Status: Connected
    Client: PhpRedis (v5.3.1)
    Drop-in: Valid
    Disabled: No
    Ping: 1
    Errors: []
    PhpRedis: 5.3.1
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 7.4.8
    Plugin Version: 2.0.5
    Redis Version: 5.0.3
    Multisite: No
    Filesystem: Yes
    Global Prefix: “wp_”
    Blog Prefix: “wp_”
    Global Groups: [
    “blog-details”,
    “blog-id-cache”,
    “blog-lookup”,
    “global-posts”,
    “networks”,
    “rss”,
    “sites”,
    “site-details”,
    “site-lookup”,
    “site-options”,
    “site-transient”,
    “users”,
    “useremail”,
    “userlogins”,
    “usermeta”,
    “user_meta”,
    “userslugs”,
    “blog_meta”
    ]
    Ignored Groups: [
    “counts”,
    “plugins”,
    “themes”
    ]
    Unflushable Groups: []
    Drop-ins: [
    “advanced-cache.php v by “,
    “Redis Object Cache Drop-In v2.0.5 by Till Krüss”
    ]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Till Krüss

    (@tillkruess)

    Hi!

    Yes the plugin is compatible with PHP 7.4.

    According to your diagnostics, you didn’t set a MaxTTL.

    What are you seeing under “Metrics”?

    alsguimaraes

    (@alsguimaraes)

    Thanks for the prompt reply.
    I did add the MAXTTL but the behavior did not change (I had tried itbefore).
    WP_REDIS_MAXTTL: 3600
    Nothing under metrics, just the message “Not enough data collected, yet”.

    Plugin Author Till Krüss

    (@tillkruess)

    Your diagnostics don’t indicate any WP_REDIS_* constants, can you try moving them further up in your wp-config.php?

    Are you seeing anything in your PHP error logs?

    Maybe the metrics can’t be stored, or maybe the shutdown handler is just ignored.

    alsguimaraes

    (@alsguimaraes)

    I was not setting those explicity. Should use the defaults, right?
    Anyways, I have added a couple constants to wp-config.php.
    I can redis-cli ping, info, etc.

    Status: Connected
    Client: PhpRedis (v5.3.1)
    Drop-in: Valid
    Disabled: No
    Ping: 1
    Errors: []
    PhpRedis: 5.3.1
    Predis: Not loaded
    Credis: Not loaded
    PHP Version: 7.4.8
    Plugin Version: 2.0.5
    Redis Version: 5.0.3
    Multisite: No
    Filesystem: Yes
    Global Prefix: “wp_”
    Blog Prefix: “wp_”
    WP_REDIS_CLIENT: “phpredis”
    WP_REDIS_MAXTTL: 7200
    WP_REDIS_PREFIX: “xp ”
    Global Groups: [
    “blog-details”,
    “blog-id-cache”,
    “blog-lookup”,
    “global-posts”,
    “networks”,
    “rss”,
    “sites”,
    “site-details”,
    “site-lookup”,
    “site-options”,
    “site-transient”,
    “users”,
    “useremail”,
    “userlogins”,
    “usermeta”,
    “user_meta”,
    “userslugs”,
    “blog_meta”
    ]
    Ignored Groups: [
    “counts”,
    “plugins”,
    “themes”
    ]
    Unflushable Groups: []
    Drop-ins: [
    “advanced-cache.php v by “,
    “Redis Object Cache Drop-In v2.0.5 by Till Krüss”
    ]

    Plugin Author Till Krüss

    (@tillkruess)

    By default, there is no maxttl 👍🏻

    Are you seeing errors in your logs? If not the shutdown handler isn’t called.

    Let’s continue this conversation here: https://github.com/rhubarbgroup/redis-cache/issues/233

    alsguimaraes

    (@alsguimaraes)

    Just figured out what was going on.
    The breeze plugin from Cloudways has a different *basic* cache that was messing things up.
    According to them “This is the basic cache that we recommend should be kept enabled in all cases.”.
    All well after disabling this Breeze cache system.

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.