WordPress.org

Support

Support » Plugins and Hacks » Yoast SEO » Empty Meta Descriptions on Posts Prevents Previews

Empty Meta Descriptions on Posts Prevents Previews

  • If we have a post that doesn’t have a meta description and click the preview changes button the page that loads is blank. I viewed the source and saw

    <!-- This site is optimized with the Yoast WordPress SEO plugin v1.4.23 - http://yoast.com/wordpress/seo/ -->
    <!-- Admin only notice: this page doesn't show a meta description because it doesn't have one, either write it for this page specifically or go into the SEO -> Titles menu and set up a template. -->
    <link rel="canonical" href="http://denovati.com/?p=4996" />
    <link rel="publisher" href="https://plus.google.com/106095850984238899136/"/>;
    <meta property="og:locale" content="en_US" />
    <meta property="og:type" content="article" />
    <meta property="og:title" content="Test | SMART Blog" />

    I went into the SEO -> Titles & Metas -> Post Types and added   to each of the Posts, Pages, Media, and Events’ Meta description template boxes and seem to have fixed this. Is there a way we can just have an empty meta description box?

    I am currently using Version 1.4.23. Note: Currently it just appears this happens with posts, not pages.

    http://wordpress.org/plugins/wordpress-seo/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Yes, you can have an empty meta description box to each post. But you have to setup a template so the plugin can generate the descriptions for you. Go into the SEO -> Titles menu and set up a template.

    So in other words, there is no option of having a blank meta description box. It must either be placed in the template or the box in the actual post? Why is this causing the preview function to present a blank page if both are empty? That seems like a bug in the programming.

    And my first post should say that I added a &nbsp; to the template. I forgot to stick it in the code tag.

    I am having the same problem on a site where we are looking at it in preview mode and if the tags are blank after updating to latest version it shows a complete blank page – turning off the plugin solves the issue, adding description to the page/post solves the issue.. I agree something in the latest version is causing this to happen as it started immediately after updating the plugin.

    hi guys
    i am having the same problem
    but , i do not know how to fix it

    adding meta description or either using %%excerpt%% in the template still does not work
    Every time i want to preview the changes the page is blank

    I tried disabling the plugin and this solves the problem

    However, i noticed one thing. It started happening ever since i attached a picture to a page. Until now i manually added the images by code ( <img … ) and they remained unattached . Yet now ever since i attached that one picture this started happening

    🙁

    any news on this issue ?

    Does the problem still exists if you switch to a default theme and deactivate all other plugins ?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Empty Meta Descriptions on Posts Prevents Previews’ is closed to new replies.
Skip to toolbar