Support » Plugin: ARVE Advanced Responsive Video Embedder (YouTube, Vimeo, HTML5 Video ...) » Empty max-width doesnt work for ajax loaded content after update

  • Resolved budy74


    Since last update, if max-width is not set in the settings, a style=”max-width:640px;” is added automatically. This doesn’t render arve-wrapper responsive in large sites.

    I solved by commenting line 59 in public/functions-shortcode.php
    //’style’ => empty( $a[‘maxwidth’] ) ? false : sprintf( ‘max-width:%dpx;’, $a[‘maxwidth’] ),

    is this a normal behaviour or a bug?


Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Nico


    I introduced this earlier (unless I made a mistake) and not in the very latest version. Its not a bug it falls back to the $content_width fixed definition of WP themes. My guess is that you theme has this set to a wrong 640px if your content area actually gets bigger then that. $content_width is usually defined in functions.php of the theme.

    In this case please set the max-width in the settings to the maximal width of your content area in the biggest scree size you can measure. You can use a screen-ruler or the browser devtools for that if you know how that works. Its to prevent the loading of to large image thumbnails when they are not needed.

    So again not a bug but unfortunately in some cases the fallback solution is not a good fit. Its better however then leading a bunch of full-hd images on peoples sites, especially mobiles. I will update the description text and include the theme definition value so people can set it appropriately.



    Hi Nico,
    thanks for your reply. You’re right: our theme defined global content_width to 640. We’re just correcting it… Strange that we did not have this problem before the update, anyway issue resolved!

    Thanks again,

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Empty max-width doesnt work for ajax loaded content after update’ is closed to new replies.