Support » Plugin: Jetpack by » Empty Jetpack ID error is not yet resolved

  • Resolved kjmtsh


    Hi, developers.

    I checked Jetpack 2.3.2 and got the result as follows.

    1. Newly installed WordPress 3.5.2 and Jetpack 2.3.2
    2. Activated Jetpack
    3. Connected to
    4. Got the error saying: jetpack ID is empty

    Error messages and all are exactly the same as many others reported. No new information. So I did an experiment like below:

    1. Newly installed WordPress 3.6-beta3 and Jetpack 2.3.2
    2. Activated Jetpack
    3. Connected to
    4. Succeeded!

    Jetpack 2.3.1 also works fine.

    Is this useful for you, developers?

    Why are other threads concerning the same issue marked as resolved? No one ever reported the plugin to work fine.

    Good luck.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Contributor Jeremy Herve


    Are your 2 sites hosted on the same server? if you still experience issues with the site that runs WordPress 3.5.2, can you please use Jetpack’s Debugger module to send us some more information about that site?

    1) Go to the Jetpack page in your dashboard.
    2) Click on the Debug link appearing at the bottom of the page.
    3) Click the link that says “click here to contact Jetpack support.”
    4) Fill in the description box and your name and email address.
    5) Click the “Contact Support” button.


    Hi, Jeremy.

    Both installations are on the same server. WordPress 3.5.2 is in one directory and beta one is in another.

    I tried installing another WordPress in another directory.

    1. Newly installed WordPress 3.5.2 (None of the default settings are changed)
    2. Installed Jetpack 2.3.2
    3. Activated Jetpack (all other plugins are not activated)
    4. Connect to

    I got the same error message: Error Details: Jetpack ID is empty. Do not publicly post this error message!

    And your suggestion.

    1. Go down to the debug link and click it
    2. Jetpack Debugging Center says: It looks like your site can not communicate properly with Jetpack, etc
    3. Click the XMLRPC file link, which says: XML-RPC server accepts POST requests only.
    4. Click ‘click here to contact Jetpack support’ link

    I clicked review/modify link and saw CLIENT_ID, BLOG_TOKEN and MASTER_USER are empty.
    And I clicked Contact Support button.

    I’ve got the mail from, which says: [server] nginx, though my web server is not nginx but Apache.

    I followed the same procedure about WordPress beta site (on the same server). The message of Jetpack Debugging Center and the result of XMLRPC are exactly the same. But CLIENT_ID, BLOG_TOKEN and MASTER_USER have the values respectively.(I didn’t send the mail)

    Is this of your help?

    Good luck.

    Plugin Contributor Jeremy Herve


    Thanks! It seems that while the problem was solved for most Jetpack users, a few site owners still experience the issue. We’re looking into it, and trying to understand which specific server configuration causes the problem.

    I’ll get back to you as soon as we’re able to find the source of the issue.

    Plugin Contributor Jeremy Herve


    Could you try to update to WordPress 3.6, and let me know if it helps?


    Hello, Jeremy.

    I’ve sent an email to support about the result.

    I’ve updated WordPress to 3.6 release version, reinstalled Jetpack and tried connecting to As we expected, it succeeded in connecting without any error.

    WordPress 3.5.2 -> failure
    WordPress 3.6 beta -> success
    WordPress 3.6 -> success

    One thing is clear: there was a problem not in the server configuration or PHP settings, but in some other places we couldn’t specify.

    Error was gone at any rate, so I mark this topic as resolved.

    Thank you for your help.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Empty Jetpack ID error is not yet resolved’ is closed to new replies.