WordPress.org

Support

Support » Plugins and Hacks » amr users » [Resolved] Empty fields pulling in "&nbsp"

[Resolved] Empty fields pulling in "&nbsp"

  • Hello,

    The list of my users for any fields that haven’t been filled in display “&nbsp” in the list. Any ideas on how to remove this? Also, the I have AMR Users Plus installed and the Alphabetical sorting doesn’t appear to be filtering users by the 1st letter of their last name like I have it setup for in the settings.

    Reference Link: http://iapsc.org/find-a-consultant/

    any help would be greatly appreciated.

    WP: 3.5.1
    AMR Users: 3.6.2
    AMR Users Plus: 2.2
    AMR Users Plus Buddypress: 1.2

    http://wordpress.org/extend/plugins/amr-users/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author anmari

    @anmari

    Hey Danny,

    Saw you post about the alpha filtering – I’ll dig into that today probably and tryreproduce my end, see what’s changed.

    RE NBSP:
    There’s a good reason for it when the list is in table format and folks want table borders to work properly in all browsers.. It’s a classic ‘fix’ for problems with borders not displaying properly around empty cells.

    I recently wrote a whole response up about it to someone else, but for some reason cannot find that post now.

    I appreciate that it is not always needed and therefore some may prefer not to have it.

    I’ll have a think about how best (without making things too complicated settings wise) to allow it to be switched off (or on for those who need it).

    Anmari,

    Thanks for getting back to me, sorry for the dual posts on both forums. I actually wrote the following jQuery to search for the &nbsp and remove it:

    jQuery(document).ready(function() {
    	jQuery("span.Street:contains('&nbsp'),span.City:contains('&nbsp'),span.State:contains('&nbsp'),span.Country:contains('&nbsp'),span.Postal_Code:contains('&nbsp'),span.Certifications:contains('&nbsp'),span.Company:contains('&nbsp')").css("display", "none");
    
    });

    Yeah, I just upgraded the AMR Users Plus to version 2.6 from version 2.2.. didn’t even notice there was an update available. But still running in to the issue.

    Plugin Author anmari

    @anmari

    fast work !
    I’d prefer a cleaner solution to the nbsp; so read next changelog updates in case.

    for info of others on tables with empty cells
    http://www.cs.tut.fi/~jkorpela/HTML/emptycells.html

    Yeah probably not the best but for right now does the trick. I have to take down the A-Z filter for now per client request. If you need a demo page with it up let me know and I can probably put that together.

    Plugin Author anmari

    @anmari

    Hi danny, please see amr-users 3.6.3 and plus 2.7 and let me know how you.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Empty fields pulling in "&nbsp"’ is closed to new replies.
Skip to toolbar