WordPress.org

Forums

amr users
[resolved] Empty fields pulling in "&nbsp" (6 posts)

  1. Danny Albeck
    Member
    Posted 2 years ago #

    Hello,

    The list of my users for any fields that haven't been filled in display "&nbsp" in the list. Any ideas on how to remove this? Also, the I have AMR Users Plus installed and the Alphabetical sorting doesn't appear to be filtering users by the 1st letter of their last name like I have it setup for in the settings.

    Reference Link: http://iapsc.org/find-a-consultant/

    any help would be greatly appreciated.

    WP: 3.5.1
    AMR Users: 3.6.2
    AMR Users Plus: 2.2
    AMR Users Plus Buddypress: 1.2

    http://wordpress.org/extend/plugins/amr-users/

  2. anmari
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Danny,

    Saw you post about the alpha filtering - I'll dig into that today probably and tryreproduce my end, see what's changed.

    RE NBSP:
    There's a good reason for it when the list is in table format and folks want table borders to work properly in all browsers.. It's a classic 'fix' for problems with borders not displaying properly around empty cells.

    I recently wrote a whole response up about it to someone else, but for some reason cannot find that post now.

    I appreciate that it is not always needed and therefore some may prefer not to have it.

    I'll have a think about how best (without making things too complicated settings wise) to allow it to be switched off (or on for those who need it).

  3. Danny Albeck
    Member
    Posted 2 years ago #

    Anmari,

    Thanks for getting back to me, sorry for the dual posts on both forums. I actually wrote the following jQuery to search for the &nbsp and remove it:

    jQuery(document).ready(function() {
    	jQuery("span.Street:contains('&nbsp'),span.City:contains('&nbsp'),span.State:contains('&nbsp'),span.Country:contains('&nbsp'),span.Postal_Code:contains('&nbsp'),span.Certifications:contains('&nbsp'),span.Company:contains('&nbsp')").css("display", "none");
    
    });

    Yeah, I just upgraded the AMR Users Plus to version 2.6 from version 2.2.. didn't even notice there was an update available. But still running in to the issue.

  4. anmari
    Member
    Plugin Author

    Posted 2 years ago #

    fast work !
    I'd prefer a cleaner solution to the nbsp; so read next changelog updates in case.

    for info of others on tables with empty cells
    http://www.cs.tut.fi/~jkorpela/HTML/emptycells.html

  5. Danny Albeck
    Member
    Posted 2 years ago #

    Yeah probably not the best but for right now does the trick. I have to take down the A-Z filter for now per client request. If you need a demo page with it up let me know and I can probably put that together.

  6. anmari
    Member
    Plugin Author

    Posted 1 year ago #

    Hi danny, please see amr-users 3.6.3 and plus 2.7 and let me know how you.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • amr users
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic