Support » Plugin: Events Manager » Empty delimiter in em-events.php

  • Resolved rmose

    (@rmose)


    WP 3.5 and EM 5.3.2.1

    After the recent upgrades, we are now seeing the following issues on (multisite installation)

    Home

    Clicking a day with more than one scheduled event displays an error at the top of the page.

    Warning: explode() [function.explode]: Empty delimiter in whatever/plugins/events-manager/em-events.php on line 195

    When clicking the month forward/back arrows in IE9, it just sits there and spins. It works in Chrome and Firefox.

    In the dashboard, Events indicates 1 event waiting, but after clicking Events, there are no pending events.

    http://wordpress.org/extend/plugins/events-manager/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi,

    I tried this one and seems to be working fine; just to narrow down the problem have you tried to temporarily:

    – deactivating all other plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).
    – switching to the default theme to rule out any theme-specific problems

    Plugin Author Marcus

    (@netweblogic)

    r.e. the warning i see how that may happen actually, will make a correction on next update that should stop that happening.

    with regards to your calendar not working, it may be because of the warning above, if not then it may be related to a conflict with another plugin and/or your theme, trying out angelonwl’s suggestion will help narrow that down.

    There was no response to the phantom pending event mentioned above, but someone else asked the same question here.

    http://wordpress.org/support/topic/events-pending-count-is-off?replies=3

    It turns out that event_status for one of the events was zero. After changing it to one, the phantom event went away.

    Plugin Author Marcus

    (@netweblogic)

    yes, someone else had an issue too a couple days ago and it’s fixed locally already

    Hi Marcus,

    thanks for helping with this issue.
    I’m having the same error message:
    Warning: explode() [function.explode]: Empty delimiter in whatever/plugins/events-manager/em-events.php on line 195

    Is there a way to locally fix this problem?

    Thanks for your help.

    Plugin Author Marcus

    (@netweblogic)

    are you on the latest update? if not try upgrading, pretty sure that’s been fixed already

    Yes you’re right. Sorry about that but I was trying at the same time to get back to version 5.3.2 to fix this issue to which you just answered.

    I now use the latest update and don’t have any problems anymore.
    Thank you for your time and help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Empty delimiter in em-events.php’ is closed to new replies.