• Resolved roneycs

    (@roneycs)


    The file backup is being performed correctly, when checking the backup of the tables, it is completely empty

    File .sql

    #
    # Powered by XCloner Site Backup
    # http://www.xcloner.com
    #
    # Host: https://www.MYDOMAIN.com.br
    # Generation Time: Apr 29, 2020 at 02:55
    # PHP Version: 7.2.22
    # Database Charset: utf8mb4
    # MYSQL innodb_version: 5.7.20
    # MYSQL protocol_version: 10
    # MYSQL slave_type_conversions: 
    # MYSQL version: 10.2.10-MariaDB
    # MYSQL version_comment: MariaDB Server
    # MYSQL version_compile_machine: x86_64
    # MYSQL version_compile_os: Linux
    # MYSQL version_malloc_library: system
    # MYSQL version_ssl_library: OpenSSL 1.0.1e-fips 11 Feb 2013
    # MYSQL wsrep_patch_version: wsrep_25.20
    # MYSQL DEFAULT_CHARACTER_SET_NAME: utf8mb4
    # MYSQL SCHEMA_NAME: utf8mb4_unicode_ci
    #
    # Database : my_db
    # --------------------------------------------------------
    
    #
    # Finished at: Apr 29, 2020 at 02:55
    #

    log

    2020-04-29 11:21:13 24459 [Warning] Aborted connection 24459 to db: 'my_db' user: 'my_user' host: 'localhost' (Got timeout reading communication packets)

    • This topic was modified 2 months, 1 week ago by roneycs.
    • This topic was modified 2 months, 1 week ago by roneycs.
Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support jimiero

    (@jimiero)

    Hello,

    Seems like you get a connection tiemout to your database, I’d suggest you to contact your hosting company and ask about why it’s getting tiemout.

    I have a machine on the linode where I run the hestiacp cpanel I own the hosting

    Plugin Support jimiero

    (@jimiero)

    In that case please check why you get a connection timeout on your database, maybe try to increase the limits so such timeout doesn’t happen.

    I’ll check

    • This reply was modified 2 months, 1 week ago by roneycs.
    Plugin Support jimiero

    (@jimiero)

    As mentioned, you need to solve your connection issue, nothing we can do on our side if you have issues with your database connection.

    note that in php I have an execution variable.

    max_execution_time = 30

    change

    max_execution_time = 300

    I will test and give feedback

    I made changes to the variables and nothing works

    Plugin Support jimiero

    (@jimiero)

    Those are php settings, you need to check your database settings.

    I made several changes to my.conf

    max_allowed_packet
    interactive_timeout
    wait_timeout

    none worked

    I did a test with another backup plugin and it is being done normally.

    UpdraftPlus was used.

    Could you please inform me on which level of mariadb do I need to make changes to run the plugin?

    [client]
    port=3306
    socket=/var/run/mysqld/mysqld.sock
    
    [mysqld_safe]
    socket=/var/run/mysqld/mysqld.sock
    
    [mysqld]
    user=mysql
    pid-file=/var/run/mysqld/mysqld.pid
    socket=/var/run/mysqld/mysqld.sock
    port=3306
    basedir=/usr
    datadir=/var/lib/mysql
    tmpdir=/tmp
    lc-messages-dir=/usr/share/mysql
    log_error=/var/log/mysql/error.log
    
    symbolic-links=0
    local-infile=0
    
    skip-external-locking
    key_buffer_size = 16K
    max_allowed_packet = 1024M
    table_open_cache = 10
    sort_buffer_size = 64K
    read_buffer_size = 256K
    read_rnd_buffer_size = 256K
    net_buffer_length = 2K
    thread_stack = 240K
    
    #innodb_use_native_aio = 0
    innodb_file_per_table
    
    max_connections=1000
    max_user_connections=500
    wait_timeout=300
    interactive_timeout=6000
    long_query_time=5
    
    [mysqld]
    skip-name-resolve
    connect_timeout = 600
    net_read_timeout = 600
    net_write_timeout = 600
    innodb_buffer_pool_size = 5G
    
    !includedir /etc/mysql/conf.d/
    
    Plugin Support jimiero

    (@jimiero)

    Hello,

    In your mysql configuration, you should try increasing your *_timeout values to a higher value and see how it goes.

    Make sure after you changed those values, you also restart mysql server.

    Variables were changed * _time

    I am using another plugin, which is working perfectly.

    Plugin Support jimiero

    (@jimiero)

    Hello,

    I don’t know what other plugins does, but the error you provided us, is coming from your environment, you can have a look on google:

    https://www.google.com/search?q=Got+timeout+reading+communication+packets&rlz=1C5CHFA_enRO882RO882&oq=Got+timeout+reading+communication+packets&aqs=chrome..69i57j0l7.186j0j7&sourceid=chrome&ie=UTF-8

    Plugin Contributor ovidiul

    (@ovidiul)

    This issue should be fixed in the latest release, feel free to re-open the ticket if the issue persists.

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.