Support » Fixing WordPress » Empty category rss feed after upgrade to 3.1.3

  • After upgrading from 2.9.3 (I think) two things happened. First, all permalinks to categories and tags died, and second, all category rss feeds came out without any items, only channel info is available. Getting this on two blogs, both installed in a subdirectory.

    I managed to find a temporary fix using the plugin WCS Custom Permalinks Hotfix but I would rather have a more permanent solution that lets me have permalinks AND working feeds + category/tag pages.

    Ps: Yes, I have tried to follow numerous threads and tutorials on how to fix this problem, for example rebuilding the htaccess, testing with another theme, switching off all plugins, etc etc, but nothing seem to work. And no, I’m not using Advanced Permalinks or Simple Tags.

    Can this please be elevated to a formal bug in wp 3.x.x ?

    Update: Oh,it has been written up as a bug, but still no solution?

Viewing 1 replies (of 1 total)
  • Luke America



    Thanks for the mention. And, I’m glad this hotfix plug-in helped.

    Unlike the trouble ticket (core.trac) states, this is NOT limited to IIS installations. Well over a thousand sites are using my plugin now … or the original prototype function … and the count grows every day … as more folks upgrade to WP 3.1+. And, very few of the folks who’ve contacted me have IIS setups. Most are LAMP. Further, WP has closed that trouble ticket relegating it to a non-issue.

    On the plug-in page you’ve mentioned, I’ve got several tips for those who can repair the WP bug without having to use the plug-in. These work for a few installations. But, as you state, it would be better to not have to have a plug-in for WP to function correctly.

    The good news is that the my plug-in should work in perpetuity … because of the way it’s coded to process internal URI’s. The bad news is that … as you mention … it does alter the displayed URL in the address bar. But … the original links do work … they’re just translated by the plug-in.

Viewing 1 replies (of 1 total)
  • The topic ‘Empty category rss feed after upgrade to 3.1.3’ is closed to new replies.