Support » Plugin: LiteSpeed Cache » Empty cart issue

  • Resolved alaid

    (@alaid)


    Hi

    I am very happy to use LiteSpeed ​​Caché, it is excellent, but recently I have a problem.

    I have WordPress, WooCommerce and LiteSpeed ​​Cache installed on a LiteSpeed ​​server, all updated in their latest version, I also use Cloudflare CDN which is currently in Development Mode to be able to observe the changes.

    The problem occurs with the cart located at the top of the site, which is initially empty, regardless of whether or not the user is logged in and regardless of the page where it is, be it home page or a category, when adding 1 This product appears and disappears from the cart located at the top of the site, showing the empty cart message, now if I add a second product, enter a category or product, I refresh the page if the product is in the cart and it appears, but at the beginning when adding the first product, the cart at the top shows the empty cart message even though the product is in the shopping cart.

    Please I need help with this issue.

    Report Number: JISDLFQA
    Report date: 04/06/2020 15:15:09

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Could you please provide step by step how can I reproduce the issue ?

    I randomly checked few pages , added 2 products, and wandering around , the cart is loading correctly

    Best regards,

    Thread Starter alaid

    (@alaid)

    Hi,

    I already explained it, just add 1 product (no more) and see the cart at the top it says empty.

    Best regards,

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    I just tested again with 1 product in cart , but it doesn’t go missing

    Please check my screen recording if I miss anything.

    https://drive.google.com/file/d/1_PvPsJh0vdcq5BukasCk_8vIuYT6aap_/view?usp=sharing

    Best regards,

    Thread Starter alaid

    (@alaid)

    Hi,

    Thank you for taking the test, but if this happens to customers, how can I please exclude the cart from the top of the cache?

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    As far as I see, the cart is using Ajax call , which is not being cached by default anyway.

    Best regards,

    Thread Starter alaid

    (@alaid)

    Hi,

    I already solved it

    In Cache / Browser / Browser Cache Settings

    I set the Browser Cache to OFF

    Best regards,

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Empty cart issue’ is closed to new replies.