Support » Plugin: Empty Cart Button for WooCommerce » Empty Cart button redirects to 404

  • Resolved Mary-Ann Zykin

    (@mazykin46)


    The Empty Cart button does not function as expected.

    Instead of redirecting to the empty cart page or the main shop page, it goes to a 404. Something seems off with the URL parameter….

    .../cart/&empty-cart=clearcart

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author WPCodelibrary

    (@wpcodelibrary)

    @mazykin46,

    Thanks for contacting us and share your concern with us.

    Do you face this issue after update our new 1.2 version or you are facing same issues with our older version as well. Also can you please send me your site URL so I can see and do more research and provide you proper solution.

    Thanks

    Hi,

    Yes, I’m facing it with both the newest version and older versions.

    Site URL is rockpointmarketplace(dot)com

    Thanks!

    Plugin Author WPCodelibrary

    (@wpcodelibrary)

    @mazykin46,

    Thanks for sharing detail with us. I see the url you provide. and found that some other argument is passed in url so it’s redirecting to 404. so might need some minor fix specific to your website. so can you please contact us at wpcodelibrary@gmail.com. Where we can discuss more about your issue.

    Thanks.

    Hi,

    I ended up solving the issue. I had the Geolocate (with page caching support) setting turned on in the Woocommerce settings, which was adding that extra URL parameter.

    Once I disabled that setting, the empty cart functionality is working as expected!

    Cheers,
    Mary-Ann

    bwnvideo

    (@bwnvideo)

    It stopped working, in fact it does not even appear in my cart anymore.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Empty Cart button redirects to 404’ is closed to new replies.