Support » Accessibility » Empty buttons causing accessibility errors

  • Resolved kallym

    (@kallym)


    When I run this page on Wave, I get the empty button error. 2 other pages in the Cafe section get the same error, but, no other pages on the site have this error. These three pages are the only pages on the site that use the restaurant menu, but don’t sdee any problem with that. When I view page source I do see 3 buttons, but they are not empty, they do have text between the tags. I don’t see anything else – button or input that could be causing the error.

    Can anyone see what might be causing the problem?

    Only buttons I see on the page. Other pages have these same buttons, so I don’t think they are causing the error:

    <button type="button" class="btn btn-default btn-navbar navbar-toggle mendef" data-toggle="collapse" data-target="#cshero-main-menu-mobile"><i class="fa fa-align-justify"></i><span class="sr-only">Toggle Menu</span></button>
    <button type="button" class="a11y-toggle-contrast toggle-contrast" id="is_normal_contrast" aria-pressed="false"><span class="offscreen">Toggle High Contrast</span><span class="aticon aticon-adjust" aria-hidden="true"></span></button>
    <button type="button" class="a11y-toggle-fontsize toggle-fontsize" id="is_normal_fontsize" aria-pressed="false"><span class="offscreen">Toggle Font size</span><span class="aticon aticon-font" aria-hidden="true"></span></button>

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • CrouchingBruin

    (@crouchingbruin)

    I don’t think those are the buttons that Wave is referring to. I think it’s actually these three buttons:

    <button type="button" id="cboxPrevious"></button>
    <button type="button" id="cboxNext"></button>
    <button id="cboxSlideshow"></button>
    

    You don’t see them when you do a view source on the page, but you can see them if you examine the page using the browser’s Inspector. It looks like those buttons are related to something called a Colorbox slideshow. Is there a slideshow that was inserted on that page but not being used?

    Hi,
    Thank you for that information. I found that it was jquery colorbox, a lightbox plugin for jquery, that was in the Nuvo parent theme I am using. I don’t see any reference to it in the theme options and am not using it on those pages. I did find the file for those pages called menufood.php that the script was enqued in. I temporarily commented it out to test it, and ran into no problems or errors, so I will add wp_dequeue_script to my functions.php file in the child theme to remove it properly from the menu pages.

    Thanks for the direction!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.