Empty Box when clicking on INSERT/EDIT IMAGE or INSERT/EDIT LINK (12 posts)

  1. mcschaffer
    Posted 8 years ago #

    I am extremely new to WordPress so please bear with my poor terminology!

    My problem is this:
    I use Firefox as my browser. When I am editing or adding a post or page and click on the "Insert/Edit Picture" button, the normal window that appears comes up but it is blank. (The same is true when I click on the "Insert/Edit Link" button. I cannot close this window. The only way to get rid of it is to click on the browser's back button.

    This happens at my home and my office.. I run Firefox at both locations.

    Any input would be helpful as I really cannot ad content right now.

    Again, thanks for bearing with my "noob" terminology.



  2. poigle
    Posted 8 years ago #

    I fixed this by going into myphp admin on my host, choosing the WordPress database, browsing in the wp_options.php and making sure the site url had "www" and wasn't just "http://sitename.com"; I had to make it "http://www.sitename.com"

    Worked like a charm.

  3. vwsage
    Posted 8 years ago #

    I went into MyPHP Admin, and can anyone describe which table you located wp_options.php ? I have located the sp_options table, but not the one you mention. Also, I can not locate the site URL any where in the database.

    Thanks, I am way past standard skill sets.

  4. mrmarsh
    Posted 8 years ago #

    No need to go to MyPHP Admin when WP will edit it for you.

    Go to "http://YOUR URL/wp-admin/options-general.php" and ensure that "WordPress address (URL)" = "the exact URL of your blog" including www if applicable.

    I had same problem. Added www to the address box and Insert/Edit boxes worked once again!

  5. LewiePaine
    Posted 8 years ago #

    I have the same problem (empty box when clicking on insert) but when I checked options-general.php I got http://www.mysite already (ie exact URL)

  6. LewiePaine
    Posted 8 years ago #

    correction...looks like I forgot the forward slash at the end of my URL


    working nicely now...

  7. LewiePaine
    Posted 8 years ago #

    unfortunately, I'm back. what was working fine simply quit working. and I made no changes in between. no new plugins, no nothing. very strange...

  8. Andrew Ozz
    WordPress Dev
    Posted 8 years ago #

    Is your blog on a subdomain? Then the url would be http://www.subdomain.mysite.com/blog/. Or you meant http://www.mysite/sub-directory/blog/.

    Also may be caching problem, see this post:

  9. LewiePaine
    Posted 8 years ago #

    my mistake...subdirectory, not subdomain

    my test blog is http://www.houseofpaine.org/bonziebean/blog/

    my Blog address (URL) in general settings is...


    (the final forward slash did not save)

    this site now works so I upgraded my main blog


    URL in general settings...


    (again, the last forward slash will not save)

    oddly, this blog initially worked, stopped working, worked one time again and has not worked since.

    I have upgraded my flash and emptied the cache/restarted ff before each test. no bad behavior. I do NOT use the visual editor.

  10. mcgilljam
    Posted 8 years ago #

    Go to "http://YOUR URL/wp-admin/options-general.php" and ensure that "WordPress address (URL)" = "the exact URL of your blog" including www if applicable.


  11. LewiePaine
    Posted 8 years ago #

    as noted above, the final forward slash will not save. however, it didn't matter on my test blog. getting the "www" in place is crucial, as mrmarsh pointed out.

    too bad the good 'ol Image Manager wasn't simply used. never had any problem with it.

    meanwhile, until this problem gets ironed out, I might suggest windows live writer.

  12. robsaxe
    Posted 8 years ago #

    Honestly, I just "upgraded" and I don't know why I did it. I had no problems with 2.3. Images won't load through unless I go to HTML view and go to image manager. Now I can't get text to wrap around the image. This sucks.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.