Support » Plugin: Advanced Access Manager » Empty page — Bootstrap Script Error

  • Resolved ahdeubzer

    (@ahdeubzer)


    Hi,

    due to a big Update of core and plugins I ran into the empty page bug (again).
    Since AAM uses bootstrap this happened multiple times but it always helped to just downgrade AAM.

    Not this time – no matter what version I use it shows me an empty page.
    A ajax script error prevents the page from showing up – also mouseover menu won’t work any more.

    I have the same site running local – with the same settings / plugins / php version – that loads the page. But it loads the scripts in a different order:
    local server aam -> vendor.js / var aamLocal / aam.js (works)
    stage server aam -> var aamLocal / vendor.js / aam.js (chashes)

    But this can’t be the point right? Any guess? Do you have a list of interfering plugins?

    Console Output:

    vendor.js?ver=4.8.2:6 Uncaught Error: 'selector' option must be specified when 
    initializing tooltip on the window.document object!

    Thanks for your help 🙂
    Anja

    PS: we have purchased the pro version.

    • This topic was modified 1 month, 3 weeks ago by  ahdeubzer.
    • This topic was modified 1 month, 3 weeks ago by  ahdeubzer.
    • This topic was modified 1 month, 3 weeks ago by  ahdeubzer.
Viewing 1 replies (of 1 total)
  • I now know where the error comes from:
    Bootstrap Javascript <– is not compatible with –> jquery.ui.tooltip
    because both use the function .tooltip()

    The plugin ‘optimizely’ registers jquery.ui.tooltip
    Any suggestion how i can filter / change sth to make both plugins work together?

    Thanks a lot!
    Anja

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.