Support » Plugin: Page Builder by SiteOrigin » emojis with page builder

  • Resolved pirate_hj

    (@pirate_hj)


    Hi SiteOrigin team,
    I’ve been using this plugin since I made my site, thanks πŸ™‚

    Q.
    Does the page builder support emojis? I tried to put emojis few years ago and few days ago and won’t work. I get emojis from http://getemoji.com

    Error symptom.
    Either the page that includes emoji don’t save it and show the pages before editing or forced to change into classic editor itself

    Sincerely,
    HeJ

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Contributor alexgso

    (@alexgso)

    Hi HeJ,

    Yes, it’s possible to add emojis using SiteOrigin Page Builder. If it doesn’t work as expected, it’s possible your hosting provider is incorrectly filtering them out. Please reach out to your hosting provider and ask if they’re using mod_security and if so, ask if it’s affecting your emojis. You may need to provide them with a login to your website so they can run some tests and identify the incorrect ruleset on their end.

    Kind regards,
    Alex

    Thread Starter pirate_hj

    (@pirate_hj)

    Hi Alex,

    Thanks for your reply, I’ll ask them πŸ™‚

    Thread Starter pirate_hj

    (@pirate_hj)

    Hey Alex,

    I’ve asked my hosting provider and mod_security was off already, Is there anything you could recommend me to fix it?

    Sincerely,
    HeeJae

    Plugin Contributor alexgso

    (@alexgso)

    Hi HeJ,

    That’s odd. We haven’t received any other reports of this happening outside of mod_security (or an equivalent) filtering them out. Can you please add an emoji to a page and before saving, send me an export of the layout? This will allow me to run some tests against your layout.

    You can export a page by clicking the Layouts button in the Page Builder toolbar. Click Import/Export and export the layout. Please upload the layout to WeTransfer.com (no email is required) or something like that, and reply with a link to the file. Once you’ve done that please try saving the page once again to confirm that the emoji wasn’t retained.

    Kind regards,
    Alex

    Thread Starter pirate_hj

    (@pirate_hj)

    Hi Alex,

    Sorry for late reply,
    Let me tell you what it happened while following your instruction,

    Made a siteorigin editor -> Added a emoji -> Exported the layout -> Published
    -> The page went to text editor itself -> Moved to pagebuilder editor -> Exported the layout

    Here is the link
    https://we.tl/t-SjuevNIdO8

    Sincerely,
    HeeJae

    Plugin Contributor alexgso

    (@alexgso)

    Hi HeeJae,

    Thanks. I’ve had a look at both of the provided layouts and both contain the emoji. Can you please link me to the page you’re working on? I’ll inspect the widget where the emoji is being added to see if I can spot anything that’s preventing it from displaying.

    Kind regards,
    Alex

    Thread Starter pirate_hj

    (@pirate_hj)

    Hey Alex,

    I had removed emojis from the page. I’ll put the test links below with the issues
    Here are some issues I’ve just seen right now.

    Test 1.
    If you make a page with page builder editor and save emoji, the editor goes to text editor so you need to change to site origin editor. Also it causes issues with the other widgets such as break html tags. Here’s the before and after layout
    https://we.tl/t-6aejFODXDV
    page link: https://hermart.kr/test1/

    2.
    Let’s say there’s a page without emojis. if you add emojis on the page, it won’t save.
    Before layout: Added emojis after saved once
    https://we.tl/t-S1z1UIPA1B
    page link: https://hermart.kr/test2/

    Sincerely,
    HeeJae

    Plugin Contributor alexgso

    (@alexgso)

    Hi HeeJae,

    Unfortunately, I’m unable to replicate this issue. Are you able to replicate this issue when all non-SiteOrigin plugins are disabled and a default WordPress theme is being used?

    Also, to confirm, this issue only affects the editor and not the page itself? I ask as I had a look at the linked page and I’m able to see the emojis you added.

    Kind regards,
    Alex

    Thread Starter pirate_hj

    (@pirate_hj)

    Ok I’ll test these in the time my site it not busy

    1.
    Disable all non SiteOrigin plugins

    2.
    change to a default theme

    Then get back to you

    Thanks
    HeeJae

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘emojis with page builder’ is closed to new replies.