Support » Fixing WordPress » Emojis do not appear in comments

  • andypp

    (@andypp)


    Hi,

    When a user leaves a comment with an emoji, only the text is displayed. If the comment has just emojis, it appears empty. Emojis work fine on post title and post content. How do I fix that?

    (Tested on WordPress 5.5.1 and Twentytwenty theme)

    • This topic was modified 1 month ago by andypp.
    • This topic was modified 1 month ago by andypp.
Viewing 15 replies - 1 through 15 (of 22 total)
  • Moderator t-p

    (@t-p)

    Are you using a plugin for emoji in comments? If so which one?

    Or, is it a feature of your theme? If so, which theme? Downloaded from?

    • This reply was modified 1 month ago by t-p.
    andypp

    (@andypp)

    Hi, no plugin for emoji in comments is installed. I tested it on the Twentytwenty theme using my smartphone. As I mentioned, emojis work fine on post title and post content but do not appear in comments.

    Moderator t-p

    (@t-p)

    I’m moving this topic over to the dedicated support sub-forum of twentytwenty theme so that theme’s developers and support community can help you with this.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Hm, I have no trouble with that on WordPress 5.5.1 and Twenty Twenty 1.5.

    This may be a plugin conflict. Please attempt to disable all plugins. If the problem goes away, enable them one by one to identify the source of the problem.

    If you can install plugins, install Health Check. On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    andypp

    (@andypp)

    Hi,

    I tested again with TwentyTwenty and all plugins deactivated, posted a comment with text and emojis from my phone (ios 13, Safari). No emojis appear in the comment, just text. I also created a new post, and emojis still work in post title and post content.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Does this happen under any other theme, like Twenty Nineteen?

    andypp

    (@andypp)

    Yes, it happens under Twenty Nineteen and Twenty Seventeen too.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Ok, then this isn’t theme specific and shouldn’t have been moved, sorry about that! I’ll move this back.

    andypp

    (@andypp)

    How do I fix this? All plugins are deactivated, no cache files, emojis do not appear on comments. Tested under Twenty Twenty, Twenty Nineteen and Twenty Seventeen themes.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Ok, let’s try a controlled test:

    👎 Will this copy and paste? 👍

    How does that go for you? I’ll try it too on my site under an iPhone running iOS 14.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    This worked properly for me: https://d.pr/i/19wyx1

    WordPress 5.5.1, Twenty Twenty 1.5, copied and pasted in Safari under iOS 14.

    andypp

    (@andypp)

    This is what I did:

    https://ibb.co/pwj897B

    This is what I got:

    https://ibb.co/4dY6cwD

    WordPress 5.5.1, Twenty Twenty 1.5, no plugins active, copied and pasted in Safari under iOS 13

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    What’s the URL of the site with the problem?

    I’d like to try posting the same test comment there myself.

    Here’s the article where I posted the test comments.

    • This reply was modified 3 weeks, 6 days ago by andypp.
    Moderator James Huff

    (@macmanx)

    Volunteer Moderator

    Hm, yeah, so I do see the problem on your site with Safari under iOS 14:

    Comment: https://d.pr/i/sFMAX0

    Result: https://d.pr/i/gkqyVI

    And, with Firefox 81 under macOS 10.15.6:

    Comment: https://d.pr/i/ldhtlc

    Result: https://d.pr/i/j1PnXa

    So, it does seem to be a problem with just your site.

    Are you sure you have no plugins active?

    What character set are you using? https://wordpress.org/support/article/editing-wp-config-php/#database-character-set

Viewing 15 replies - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.