Support » Plugin: Disable Emojis » Emojis are displayed as unknown character

  • Resolved entrapped

    (@entrapped)


    Hi,
    when enabling the plugin all emojis are displayed as as small box (Unknown character).
    I guess the desired behavior is that the emojis are displayed as the “emoji source code”?

    Any ideas?

    Thank you
    Chris

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Ryan Hellyer

    (@ryanhellyer)

    This is just because your browser does not support that particular emoji. The plugin removes the built in support for emoji’s in WordPress core, but it does not remove the emoji characters which may have been added to your content.

    Same here, when the plugin is enabled unknown character is displyed instead of a colon followed by a right parenthesis

    I tested latest Firefox, Chrome and Safari.

    See screen here:
    http://omverkstan.se/wp-content/uploads/2017/05/smily01.png

    • This reply was modified 6 months, 3 weeks ago by  cykelgbg.
    Plugin Author Ryan Hellyer

    (@ryanhellyer)

    The plugin is called “Disable Emoji’s”.

    It disables the built in functionality in WordPress for displaying emoji’s (when the browser doesn’t support it natively).

    So the behaviour you are describing is expected. That’s what the plugin is meant to do.

    Plugin Author Ryan Hellyer

    (@ryanhellyer)

    … instead of a colon followed by a right parenthesis

    That’s an emoticon. There’s a setting in the WordPress admin panel for turning those off. WordPress switched from image based emoticons to emoji’s a while ago. This is unrelated to the disable emoji’s plugin.

    Plugin Author Ryan Hellyer

    (@ryanhellyer)

    Here is a plugin I wrote which makes the smile emoticons in WordPress work with the native smiley emoji in most browsers.

    https://stuff.hellyer.kiwi/temp/make-smile-emoticon-work.zip

    Thanks for explaining, and both plugins.

    Amazing how much code has to be added to display a colon next to right parenthesis πŸ™‚

    Would it be possible to add support fΓΆr πŸ™ ??

    Plugin Author Ryan Hellyer

    (@ryanhellyer)

    There’s a line in the plugin which says this:
    $content = str_replace( ':)', ':D', $content );

    That’s just converting from : with ) to : with D.
    You can add another line to do the same thing, but just change it so that it’s converting πŸ™ to whatever works for displaying a frowning face (I don’t know what that is, I only stumbled across πŸ˜€ by accident).

    If you figure out which character to use, I can add it into the plugin for you if you like.

    Found this:
    http://www.alanwood.net/unicode/emoticons.html

    added new line as you suggested using decimal format
    $content = str_replace( ':(', '😦', $content );

    Now both πŸ™‚ and πŸ™ works fine.

    Unfortunately smile wont display on mobile πŸ™

    Do you think it is possible to make wordpress display a colon followed by a parenthesis instead of an icon, just like i wanted from the begining?

    :) and :(

    Plugin Author Ryan Hellyer

    (@ryanhellyer)

    Yes, just turn off emoticons in your admin panel. I mentioned this earlier in the thread.

    this option can be accessed at wp-admin/options-writing.php

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Emojis are displayed as unknown character’ is closed to new replies.