Support » Fixing WordPress » Emergency!!! WordPress no longer recognizes my admin user log in

  • Resolved kelly1878

    (@kelly1878)


    Hello,

    I currently run a blog at http://thelesbianlifestyle.com. I had been getting an error when loading the blog telling me I was using too much CPU in a 60 second rolling window. It stated I may be running too many PHP scripts.

    I decided to log on to my server and putz around. MISTAKE. I Noticed a section on my Bluehost.com control panel that talked about PHP scrips and SQL. I clicked on a few but didn’t do anything. After reading I could tell it was above and beyond my knowledge.

    I also opened my ftp. I went into my WordPress Content/ Themes folder. I noticed that the Default and Classic theme were still there. I had a custome theme made so figured I would never need them so I deleted them.

    I clicked back on my blog and it opened up just fine. I went to login and plugged in my user name and password. It is now telling me that I am not a registered user. This sucks, as I am the blogs admin and it was under that user name that I make all the changes.

    I did try to register using another email address. I never got an email confirmation to the new address.

    At this point I am totally locked out of my blog and in a state of panic. Any help would be wonderful!

    I’ve learned my lesson,

    Kelly

Viewing 15 replies - 1 through 15 (of 29 total)
  • I’d restore the wp-content/themes/default folder. In fact, this is a good time to upgrade to 2.6.5. See Upgrading WordPress Extended.

    As for the login, here’s some things to try if you can’t login after the upgrade:
    1. logout or logout with http://www.yourdomain.com/wp-login.php?action=logout
    2. disable all plugins–if necessary read How to deactivate all plugins when not able to access the administrative menus?
    3. clear cookies
    4. exit browser
    5. make sure local firewall is not causing problem
    6. login with http://www.yourdomain.com/wp-login.php

    If WordPress is installed in something other than the root folder please take that into account for the above url examples

    Please let us know what does solve your problem.

    The issue is that I’ve always upgraded with the WP Automatic Upgrade plugin. I don’t know how to do it manually.

    Here’s another note on what I did. I was in the Bluehost.com control panal and click on PHPMyAdmin. I saw that there was a list of plugins in this database. Some of which I was no longer using. I deleted the wp_wassup plugin. After frantically doing some research I see that i have a wp_usermeta database.

    Did deleting the wp_wassup plugin in PhPMyAdmin mess this up. I’m sorry I’m just freaking out at the moment. I have a lot going on at the blog right now and want to get this fixed without having to start all over again.

    wp_wassup would not interfere with wp_usermeta.

    Everything in that table refers to access levels, bios and stuff for the users.

    I’m thinking I may have messed with a database.

    Moderator kmessinger

    (@kmessinger)

    First stop clicking around :^) Contact your host and see if they, by pure chance, have a back up of your db.

    Otherwise or in addition, if you don’t want to upgrade or can’t follow MichaelH from the second paragraph and don’t forget to check the links he provided.

    You can also try changing your user and password directly through the database using phpmyadmin: http://www.tamba2.org.uk/wordpress/phpmyadmin/ however, I agree with kelly1878 about seeing if just by chance there is a backup available.

    Sorry, kelly1878, I meant I agree with kmessinger about what he advised for you. 🙂

    Thank you MichaelH for this tip:
    2. Disable all plugins–if necessary read How to deactivate all plugins when not able to access the administrative menus.

    Like kelly1878, my host is Bluehost, and I upgraded to 2.6.3 using Fantasico, and it seems the program did not deactivate the plugins — which resulted in WP not recognizing my Username and password.

    It’s took a bit of hunting but I finally found how to do the following on phpMyAdmin:

    In the table wp_options, under the option_name column (field) find the active_plugins row
    Change the option_value field to: a:0:{}

    After that, I was able to log in to my dashboard, deactivate the plugins, and do the upgrade to 2.6.5 using Simple Scripts (through my cPanel on Blue Host) without any problem.

    Cheers!

    Kelly here. My webdesign company wants to charge me 100/hr to look into this issue. I attempted the suggestions above to no avail. If anyone can give me any further help on this matter I would be in debt to you. I do not have the money to have this researched, nor do I have the know how to further researchi it myself.

    At this time I am not able to log on to my WordPress account. Nor are any of the over 200 registered authors. No new user registrations are being processed.

    I attempted the fix that PyKorry suggested and this did not work for my blog. I am still currently in a panic and would be so greatful to anyone who could work with me to look into this issue further.

    Thanks in advance,

    Kelly

    whooami

    (@whooami)

    Member

    I attempted the suggestions above to no avail.

    which suggestions?

    // taking notice of all the ads on that site. thats called $$$

    I do not have the money to have this researched

    Just pointing out that while we are happy to help you to the best of our ability for free, no-one here is blind or dumb.

    I never thought anyone here was blind or dumb. Quite the contrary. I don’t charge hardly anything for the ads and the money raised goes to the blog awards the site hosts the first of each year. I am by no means attempting to fool anyone into helping me. I am honestly at a standstill with this issue.

    I tried the suggestions given by MichealH and PyKorry. I did notice something however. BernardBorealis suggested that I try changing my user and password directly through the database using phpmyadmin: http://www.tamba2.org.uk/wordpress/phpmyadmin/.

    I went to this site and attempted to follow the instructions. I noticed that I do not have a wp_users database, but do see the wp_usermeta. Could it be that I mistakenly deleted the wp_users database and that is causing the issues? If so is there a way to correct this?

    My webdesign company wants to charge me 100/hr to look into this issue.

    I’d be downloading a copy of my database and heading for the airport by now. LOL

    @ whooami

    what do you do around here but just rag on people all day who are frustrated and looking for help?

    you have nothing constructive to offer. getting outside once in awhile may help you get some perspective.

    @ KellyLes

    just ignore whooami’s posts. he just rags on people here all day. hope you get your issue sorted.

    whooami

    (@whooami)

    Member

    hey bob, why dont YOU help her, big guy?

    wtf are you anyway? Youve been here 6 months and EVERY single (-1) one of your posts is about your blog being hacked.
    Your quite the mentor, right?

    Oh and ps, im a female. get your gender right, BOB. Believe it or not, they allow women on the web.

    Now, since you have answered the question, and then some, I can tell you what the problem is, Kelly.

    I do not have a wp_users database

    Right there.

    Do you have backup of your database?

    Failing that, I can give you a query that will recreate the table, and make an admin account, but your 200 users are going to be SOL.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Emergency!!! WordPress no longer recognizes my admin user log in’ is closed to new replies.