Support » Plugin: Events Made Easy » EME no longer sends emails

  • Resolved nyks-barton

    (@nyks-barton)


    Hi,

    around a week ago, EME has stopped sending any emails. There are several emails missing (booking-confirmation for the guests, booking-notifications for the admin).

    I tried to find the bug by using an email-protocol; it shows, that EME has not tried to send emails.
    I send the EME test-email, which works perfectly. But no email-booking-confirmations were send.

    In “EME / actions for cleanup” I found the notice, that there are 14 e-mails in the queue.
    These mails are delayed more than 5 days now.

    I’m not using a dedicated cronjob, but until last week, it works fine with the wordpress-cron.

    Why these are not send? How to fix it?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Franky

    (@liedekef)

    Check your setting “Send out queued mails in batches of” in the EME menu “Scheduled actions”

    Thread Starter nyks-barton

    (@nyks-barton)

    That setting is “50” (checking once an hour).

    What should this setting be? Changing to “1” and 5 minutes?

    I haven’t changed anything there. Before october 26th, the mails were send instantly.

    • This reply was modified 1 year, 2 months ago by nyks-barton.
    Plugin Author Franky

    (@liedekef)

    Well, I have it at 10 mails every 5 minutes. But even 50/hour should work.

    If the test mail works, it means the EME settings are ok, so that shouldn’t be the problem. However, check your email sender: when defining an event, the sender is set to the contact person of the event if the global EME settings for “Default email sender name” and “Default email sender email” are empty. If those settings are not emty, those are taken as sender. If that sender is not allowed to send emails from your mailserver, it won’t work.

    • This reply was modified 1 year, 2 months ago by Franky.
    Thread Starter nyks-barton

    (@nyks-barton)

    I’m not sure, that I found the correctly settings you mentioned.

    I did not changed the default setting with sender names etc.
    There are no other wordpress users in the WP installation (just a single admin, a single event author/contact person), everything with the same email-adress.

    Testmail works (Events made Easy / Email-Mangagement / Test-E-Mail). Test-E-Mail is delivered instantly.
    Wordpress-Emails work fine, too (tested it by requesting the wordpress-passwort-recovery).
    But still no email-confirmations after booking an event (since oct 26th).
    I also found the email-log in EME (“e-mail-management” / “search emails”): this shows me all emails until oct 26th.

    Could you describe me, where I find the settings you mentioned?

    • This reply was modified 1 year, 2 months ago by nyks-barton.
    Plugin Author Franky

    (@liedekef)

    The setting is either in the general EME settings, tab “mail”. Or the per-event settings, concercing “contact person”.
    Also: you are mentioning that you see the email log until 26th of Octber, but nothing after that. So: have people booked after that time? And if so: are your events configured to send out emails after RSVP arrives? An empty email subject/body will not send out a mail, nor if you have the option “Enable the RSVP e-mail notifications?” (and the options below that) active in the generic EME options, tab “Mail”

    Thread Starter nyks-barton

    (@nyks-barton)

    > general EME settings, tab “mail”
    All setting fields are blank.

    > per-event settings, concercing “contact person”
    in the boxes on the left, my admin-user is choosen (email-domain identical with website-url, should be fine)

    Yes, there were several bookings after 26th oct. For the same, unchanged event.

    I’ve 3 recurring events, with identical settings, which have not been changed since 2020.

    There are always going e-mails into the EME queue. I cleaned the email-queue in the “cleanup/maintenance-section”; that has deleted the 14 Mails in the queue, which seems to be the correct number of missing emails. After that, I did a new test-booking. The expected two mails were saved into the EME-email-queue, but not send.

    Obviously, the the queue is not processed anymore (after oct 26th).

    Plugin Author Franky

    (@liedekef)

    Ok, then there are 2 possibilities: either some error is triggered when EME tries to process the queue (should be visible in your website error logfiles), or your wp-cron is no longer working as expected.
    For the second possibility, you can install “Advanced Cron Manager” and then ‘in the Tools menu) check all cron schedules with their latest execution time, execute a planned action (like “eme_cron_send_queued”) yourself etc …

    Thread Starter nyks-barton

    (@nyks-barton)

    I found no relevant errors in my serverlog.

    Advanced Cron Manager installed; “eme_cron_send_queued” is listed there. I executed it manually, and the emails were send out 🙂

    Obviuously its a issue with the WP-Cron. I found a huge amount of entries in scheduled actions with “rank_math/search_console/get_analytics”. I deactivated Rank Math now, and i will wait to see if that solves the problem.

    I will let you know 🙂

    Thank you for the fast support!

    Plugin Author Franky

    (@liedekef)

    ok, for now I’ll mark ths solved then 🙂

    Thread Starter nyks-barton

    (@nyks-barton)

    Thank you again. It wasn’t EME’s issue.

    The solution was almost too simple.

    I found the
    define( ‘DISABLE_WP_CRON’, true );
    in my wp-config; its quite appearently for the issue, but I’m sure, I have not added this line (manually) to the config within a week. Since I have not founds hints of malware, I guess, it has to be an plugin or an missclicked option in the hosting-WP-toolkit.

    Whatever, issue solved, thanks alot 🙂

    • This reply was modified 1 year, 2 months ago by nyks-barton.
Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘EME no longer sends emails’ is closed to new replies.