Support » Fixing WordPress » Embeds not working

  • Resolved Shane Gowland

    (@thewebatom)


    Hi all,

    Just updated to WordPress 4.4 and was excited to try the new ‘WordPress Embeds’ feature, but unfortunately I can’t get it to work.

    I’ve tried pasting both internal and external (from other WP 4.4 sites) links into the editor – both Visual and HTML, but I’m not getting any embed showing up on the front end. It’s not working on any of the sites I’ve updated so far.

    Other oEmbed providers – such as Youtube – are continuing to work as expected.

    I would appreciate if someone could help me to diagnose this problem. Is there any changes that need to be made to my theme(s), or a server configuration problem preventing WordPress from being able to access the data endpoint?

    Thank you.

Viewing 15 replies - 1 through 15 (of 23 total)
  • Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Are you sure that *both* sites are WordPress 4.4? The site you’re embedding from needs to be 4.4 to act as an oEmbed provider, then the site you’re embedding to needs to be 4.4 to know what to do with it.

    Yes, I’ve only tried it between 4.4 sites. Also tried disabling any caching plugins, but to no avail.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Ok, a few things:

    1. Are you using any sort of caching plugin, or do you see a “Clear/Purge Cache” button in your Dashboard or admin bar? If so, would you please try clearing the cache?

    Note: You do not need to install a caching plugin at this point just to clear a cache you don’t have. If you don’t have a caching plugin or a way to clear a server-level cache, just say so. 🙂

    2. Do you see any JavaScript errors after pasting the URL in the editor like any normal embed?

    https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    3. Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the Twenty Fifteen theme to rule-out a theme-specific issue (theme functions can interfere like plugins).

    4. What is the URL of the post you’re trying to embed, and what is the URL if the site you’re trying to embed it on?

    1: A mentioned previously, I disabled the cache plugins while testing. Have since re-enabled them (experiencing unusually high traffic today so leaving them disabled is not really an option). Have cleared them all, though, as is normal after an update.

    2: No JavaScript errors. The Google Chrome console is completely clear.

    3: I changed one site to Twenty Fifteen to test, but can’t disable all plugins as it’s on a multisite install and requires domain mapping and a few other things to continue functioning. Have another site that just uses Twenty Twelve and no plugins – same problem.

    4: The sites I’ve tried embedding posts on (and from) are shanegowland.com, aviculture.co, singularlabs.com, gowland.me and tehsims.com

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Ok, I see that all 5 sites are publicly accessible, running WordPress 4.4, and they’re all HTTPS.

    They all have great SSL certificates too, using https://www.ssllabs.com/ssltest/analyze.html?d=shanegowland.com&hideResults=on as an example (no reason to link to the other 4).

    I was able to reproduce the issue on my test site using https://shanegowland.com/tech/2015/iobit-resorting-to-comment-spam-to-improve-their-reputation/ and https://tehsims.com/miscellaneous/aroundthesims-annual-advent-calendar-brings-daily-christmas-downloads/ they simply appeared as plain text URLs.

    I was however able to embed posts from my personal site http://macmanx.com/

    Are you able to embed anything from there?

    Also, can you at least let us know what plugin you’re running? My immediate guess is that an overzealous security plugin is blocking it.

    Hi James,

    It seems I can embed content from your site, provided I add https to the beginning of your URLs.

    Each site has a different set of plugins. The following are used by shanegowland.com which I’m going to focus on for debugging:

    Akismet
    All In One SEO Pack
    Broken Link Checker
    CloudFlare
    Gallery with No Image Links
    Jetpack by WordPress.com
    Personal Favicon
    Quick Page/Post Redirect Plugin
    SyntaxHighlighter Evolved
    WordPress MU Domain Mapping
    WP Super Cache
    WP-PageNavi
    WP-Sweep
    Yet Another Related Posts Plugin
    ZillaLikes

    I just tried disabling CloudFlare – which didn’t even occur to me before – but it had no effect.

    The server is also running some security software – ModSecurity and ‘ConfigServer Security & Firewall – csf v8.08’

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    Are your SSL certificate’s from CloudFlare’s Universal SSL, Let’s Encrypt, or one of the $$ certificate authorities?

    Yes – all (except for one which is from Comodo) sites use CloudFlare’s SSL, but I have a couple of non-SSL sites that aren’t producing embeds either.

    Did a test on my blog I just updated. When I pasted James’ post in my Visual Editor I saw the embed within the editor; however, just a text version of the link was present in the published post. I stuck a Tweet in there as well and it worked fine.

    I tried this post https://shanegowland.com/tech/2015/the-decline-of-the-mac-app-store/ and I didn’t get the embed in the Visual Editor or the published post.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    What’s the URL of the Comodo site? Also, can you share the URL of one or two non-HTTPS sites affected?

    Same thing when I paste one of my posts on my live blog to my local development blog, I see the Embed in the Visual Editor, but not in the published post.

    Hmmm… it’s like some javascript or something that is loading on the backend isn’t loading on the front-end.

    Moderator James Huff

    (@macmanx)

    Volunteer Moderator 🚀

    That seems to be the case. This finally convinced me to take the forced-HTTPS plunge at https://macmanx.com/ in hopes of tracking this down further, but no such luck. 🙁

    And while I can still embed posts from my primary site on my test blog, I can’t from any of Shane’s site’s, so I’m not convinced the issue is on the end of the embedding blog. It seems to be something from the source blog’s end.

    Even put both my blogs on the Twenty Sixteen theme. Both of mine are http. I can see the embed in the Visual Editor but not the published post. Twitter embeds work fine.

    Wonder if some option are setting must be activated to work?

    After reading: https://codex.wordpress.org/Embeds I wonder if it’s not passing the security whitelist or something and the sites have to be added or something?

    I doubt I’d ever use it much except for YouTube, Twitter and such and not XYZ site. Still, be nice to understand what’s going on and why it isn’t working.

    Moderator Marius L. J.

    (@clorith)

    Hi,

    So I was actually hitting this roadblock while testing 4.4 in RC.

    It seems the CloudFlare plugin causes a bit of issues (see https://wordpress.org/support/topic/plugin-breaks-new-wordpress-oembeds-in-44?replies=1 for my report of it), could you try disabling CloudFlare proxying and disabling the plugin to see if that does in fact solve it (I’ve not had a chance to test it after the release, but since they’ve not responded to my post I fear it may still be a legitimate issue)

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Embeds not working’ is closed to new replies.