Support » Theme: Mon Cahier » Embedding Tweets

  • I’ve been trying to embed tweets onto my blog. I tried copying the individual tweet from Twitter and pasting it directly into the body of my blog post. I’ve also hovered my mouse over the timestamp, right-clicked, and selected “Copy Link Address”.

    What I got in return was a block formatted quote, that has all of the links and wording of the original tweet, except that it looks like a quote.

    How do I get the actual tweet embedded? Is this a theme issue?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Theme Author Christine Rondeau

    (@crondeau)

    Volunteer Forum Moderator

    Hi MsWalton,

    I just tried to embed a tweet twice and it worked, but I had to switch to Text view.
    What you are writing your post, there are tabs on the far right Visual and Text.

    When pasting the embed code that twitter provides it doesn’t work in the visual mode.

    Maybe try that?
    If that doesn’t work, then maybe try disabling your plugins to see if one of them is causing havoc?

    Hello Christine,

    I’ve tried the following things:

    [embed]https://twitter.com/lenovo/status/578904749799567360[/embed]

    [embed]http://twitter.com/BarhamVA/status/387715064759074816[/embed]

    [embed]http://twitter.com/MsWalton/status/579104726618259457[/embed]

    The only method that sort of worked is listed below, however, the image attached to the original tweet doesn’t show when I preview it. I can’t figure out what I’m doing wrong. I’ve disabled all of my plugins.

    <p>Flying Car Set to Take Off in 2017, says @Aeromobil http://t.co/HEqrnmwqd3 @engadget pic.twitter.com/p8y6XhSBR9</p>— Lenovo (@lenovo) March 20, 2015

    Theme Author Christine Rondeau

    (@crondeau)

    Volunteer Forum Moderator

    Adding the url:
    https://twitter.com/lenovo/status/578904749799567360
    is all that should be required.

    I just tested it and I can see the tweet like so:

    View post on imgur.com

    I’m not sure why it wouldn’t work.
    Have you tried switching theme to see if it works with another? If it doesn’t, then maybe there’s something else at play? Server, or firewall, not really sure.

    Moderator Jan Dembowski

    (@jdembowski)

    Brute Squad and Volunteer Moderator

    If your site is the one in your forum profile then it looks like you have some other plugins activated and that could interfere with the oEmbed.

    It shouldn’t but if wrapping it in [embed]...[/embed] doesn’t work… Try deactivating all of your plugins, clearing your browser cache and log in again. Then on a new draft post (with the plugins all off) try embedding that tweet again.

    This is a constant issue for you. You can check out what a mess it is at http://www.jumapili.com/?s=twitter
    I have done all of what was suggested even deactivated all of the plugins… still a mess?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Embedding Tweets’ is closed to new replies.