Support » Plugin: Elementor Website Builder » Embedded Youtube Videos doesn’t work anymore after 3.1 Update

  • After update to Elementor 3.1.0 the embedded youtube video function doesn’t work anymore.
    After rollback to 3.0.16 it works.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Thread Starter jpkarmatech

    (@jpkarmatech)

    clarification:
    this problem occurs only with youtube enhanced dataprotection.
    with direct youtube embedding it works with 3.1.0!

    Plugin Support shilo-ey

    (@shiloey)

    Hi @jpkarmatech

    Thanks,

    What do you mean by enhanced data protection?

    Can you specify which settings you added to your Video widget?

    Thanks

    Thread Starter jpkarmatech

    (@jpkarmatech)

    Hi shilo-ey
    YouTube offers the possibility to insert an enhanced data protection link to fulfill EU Data-Protection Law (DSGVO), here a sample of a data protected link:

    <iframe width=”560″ height=”315″ src=”https://www.youtube-nocookie.com/embed/mL6WvNCCWu8&#8243; frameborder=”0″ allow=”accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture” allowfullscreen></iframe>

    The Link without enhanced data protection is as follow:

    With the version 3.0.16 of Elementor I can embed the above mentioned data-protectec Youtube link, but with 3.1.0 the Video-Widget is not shown.

    Plugin Support shilo-ey

    (@shiloey)

    If you are placing the code

    <iframe width="560" height="315" src="https://www.youtube-nocookie.com/embed/mL6WvNCCWu8" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>

    It won’t work for you?

    Are you placing this embed code using HTML widget?
    Using a Video widget?

    Thread Starter jpkarmatech

    (@jpkarmatech)

    Hi shilo-ey

    No, with your given code, it doesn’t work with 3.1.
    With 3.0.16 it works.

    I am using the Video Widget of Elementor and I am copying the above mentioned code of enhanced data protection link into the field ‘Link’.
    Up to 3.0.16 the embedding funktion worked fine. There are several Websites using embedded Videos (enhanced data protection) with the same problem.

    I am using the OceanWP-Theme.

    Thread Starter jpkarmatech

    (@jpkarmatech)

    Perhaps following Link shows, what I mean with ‘enhanced data protection’:
    https://github.com/WordPress/gutenberg/issues/12701

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Embedded Youtube Videos doesn’t work anymore after 3.1 Update’ is closed to new replies.