WordPress.org

Support

Support » Themes and Templates » Embedded video don't shrink to fit cards

Embedded video don't shrink to fit cards

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi, where you able to get a fix for this? I’m having the same problem with the last update

    Thanks

    Temp fix, try changing the video sizes to

    width=”340″ height=”315″

    chrissabato
    Member

    @chrissabato

    After some digging i figured out that it was only happening to vimeo videos.

    Open themes\pinboard\scripts\fitvid.js

    on line 49…
    change:
    “iframe[src^=”https://player.vimeo.com’]”,
    to
    “iframe[src^=//player.vimeo.com’]”,

    There is a deeper issue. I’m not sure why the vimeo links are being generated without the ‘https:’, but this fix worked for me.

    ryanscreativeuniverse
    Member

    @ryanscreativeuniverse

    I am having the same issue but not using Vimeo videos. The videos I embedded are from YouTube. And yes, only since the last update. Used to work fine. Let me know if any of you figure out why. Thanks.

    This keeps happening with my youtube videos too.

    This is something with the last update. I’ve noticed that videos don’t have the following <div> around the iframe as they did before.

    <div class=”fluid-width-video-wrapper”>

    I’m guessing something’s wrong with fitvid.js

    Thanks chrissaboto – that vimeo thing had been bugging me for a while – your fix works a treat
    YouTube vids have remained OK for me…

    Dave Clements
    Participant

    @thewanderingbrit

    I’m having the same issue, but with videos from TED. I am stuck on 1.1.10 until this gets fixed.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Embedded video don't shrink to fit cards’ is closed to new replies.