Support » Fixing WordPress » Embedded php scripts no longer working

  • xprt007

    (@xprt007)


    Hi

    I use 3 scripts, one php, the other javascript to embed some foreign content on that page. They were all working until yesterday. What happened is that I transferred 2 sites to another host. As soon as the domain resolved a couple of hours later, I noticed the php based script content, supposed to appear just below the text with white background has been blank up to today, 24 hours later.
    The php script, is there and intact & using “include” is supposed to print some content.

    <?php 
    include "http://www.blablabla.com/abc/single.php"; 
    ?>

    If I try to load the non-Wordpress php page directly,
    as http://www.blablabla.com/abc/single.php
    it loads normally.

    Nothing has otherwise changed on the site. The content under Giveaway 2 & 3 are javascript based & gets printed normally.

    I have always had the plugin “PHP Code For Posts” on both sites. Right now, though even after trying using its shortcodes, something i have never used before, no content is printed.

    Could there be any specific server requirements for WordPress missing at new host required to embed php code?

    Thank you in advance.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • You need allow_url_include to be enabled to use urls with include(), its turned off by default because of the obvious security risks.
    http://php.net/manual/en/filesystem.configuration.php#ini.allow-url-include

    xprt007

    (@xprt007)

    Thank you for the response.
    I contacted the host & explained the problem, but mysteriously, it is one of the many php functions available elsewhere they consider a security risk and implied it’s unlikely to be available any time soon.
    🙁
    I have had to revert to a javascript version, which for some reason has some issue.

    • This reply was modified 2 years ago by xprt007.
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Embedded php scripts no longer working’ is closed to new replies.