WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Embedded font only working on one page (6 posts)

  1. ikbenbritt
    Member
    Posted 2 years ago #

    Hi there,

    I just embedded a font in my theme but the weird thing is.. It's only working on the first page of my website. The page you enter (index.php) shows my blog titles in the right font but when you go to a single page or the next page it's not working anymore..

    My site is: http://brittplaza.nl/tstsrvr/

    Any idea how this is possible and more important, how to fix it?

    Thank you!

  2. Andrew
    Forum moderator
    Posted 2 years ago #

    You have this particular error on one of your font-problematic pages;

    Failed to load resource: the server responded with a status of 404 (Not Found) http://brittplaza.nl/tstsrvr/featured/Sackers.ttf

  3. ikbenbritt
    Member
    Posted 2 years ago #

    As fas as I'am concerned I have no feautured map on my server. Do I need one?

    I did the following, in my head.php I put:

    <style type="text/css">
    @font-face {
    font-family: Sackers;
    src: url("Sackers.eot") /* EOT file for IE */
    }
    @font-face {
    font-family: Sackers;
    src: url("Sackers.ttf") /* TTF file for CSS3 browsers */
    }
    </style>

    and then in my css I used 'Sackers' as my main font.

  4. Andrew
    Forum moderator
    Posted 2 years ago #

    Try using a more specific URL path to your font.
    E.g

    ("/wp-content/themes/yourThemeName/Sackers.eot")
  5. ikbenbritt
    Member
    Posted 2 years ago #

    Aaaah it's that simple!

    Thanks you veeeeeeeeeeeery much!

  6. Andrew
    Forum moderator
    Posted 2 years ago #

    And Thank you for contributing to the WordPress.org community :)

Topic Closed

This topic has been closed to new replies.

About this Topic