Support » Plugin: PowerPress Podcasting plugin by Blubrry » Embedded audio not playing

  • Resolved demonboy



    I set up my podcast feed many years ago. In fact I don’t even know how or where the feed was created and the last episode was published ten years ago, but it still appears on Spotify etc. I am now releasing a new series of podcasts and trying desperately to remember how this all works.

    All of my previous podcasts appear on this page on my blog:

    Each podcast is a blog post under the category ‘podcast’. My new episode has been published on my blog and appears on this page. However the embedded audio player is not playing anything, even though the plug-in has confirmed its existence.

    More importantly, when I view the XML feed file, this new episode does not appear, and it is not appearing in Spotify.

    The feed URL is

    I expect it to take a while to appear on Spotify etc but why isn’t this showing in the XML file? That should be instant, no?


    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Thread Starter demonboy


    Please ignore the first part of this post. I flushed the RSS cache in my caching plugin and that seems to have done the trick. The new episode is now appearing in Spotify.

    I’m still having issues with the embedded player though. I have tried to include the shortcode [powerpress_playlist] on the page It should appear just before the blue section.

    When editing the page (using Cornerstone) the player appears but only as a simple player. No episode info, no image etc. On the front end the player doesn’t even appear. I’ve purged all pages from cache and tried a number of browsers from PC to phone, but that player is not appearing.

    I have enabled the playlist feature in the settings.

    Any thoughts?

    • This reply was modified 1 year, 2 months ago by demonboy.
    Plugin Support Mike Dell


    I’m seeing the playlist player on this page:

    It could be browser caching?

    Contact Blubrry Support directly and we can look a bit deeper.


    Thread Starter demonboy


    Hi Mike, thanks for getting back to me. Yes, it seems to be a caching issue. It’s displaying for me too now. Thanks, all sorted.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Embedded audio not playing’ is closed to new replies.