• Resolved mburke79

    (@mburke79)


    Hi,

    I am trying to embed a youtube video. I’ve tried using a shortcode from my theme, and I’ve also tried using the embed link straight from youtube. The result is the same. It seems that only the bottom video controls are visible, the rest of the video is cut off.

    I’ve tried a few things but I can’t resolve this. Can you help.

    Please reference http://happyrescues.org to see an example.

    Thanks

Viewing 15 replies - 1 through 15 (of 17 total)
  • @mburke79

    Sorry you’re having difficulties, I’m sure we can this resolved.

    I’m not seeing any Popup Maker popups on your site.

    Thank you for being patient.

    Thread Starter mburke79

    (@mburke79)

    Hi Walter,

    I ended up going with two other plugins – one for the auto-popup on page open, and one with an image anchor for clickable popup.

    I’d love to solve this problem though, because your plugin does both.

    How would you like me to proceed?

    Mike

    @mburke79

    I would suggest just making a test page where you’ve replicated the issue and that way we can resolved the problem.

    Also, WP comes with oEmbed, you should just be able to paste the YouTube Vid URL into the Popup Content Editor. Try that when you set the test page up and see if that fixes the issue.

    Thread Starter mburke79

    (@mburke79)

    Hi @waltmesser,

    Ok I set up a test page at http://happyrescues.org/popup-test

    I pasted the URL as you said. On the Content Popup Editor, everything seems fine, but you will see the result on the test page.

    Could this be a conflict with XStore theme?

    Thanks
    Mike

    @mburke79

    Try inputting the YouTube Vid Shortcode within a <dev> element inside the Popup Editor:

    <div style="width:400px;height:300px;"> [vid_shortcode] </div>

    Or you could do something responsive like this:

    <div style="width:100%;height:auto;"> [vid_shortcode] </div>

    Let us know if that helps.

    Thread Starter mburke79

    (@mburke79)

    @waltmesser

    I used the second option – and all it did was make the pop-up area bigger. Video is still a small strip. http://happyrescues.org/popup-test

    When you say [vid_shortcode], are you referring to the shortcode from Visual Composer? Thats what I used…

    <div style="width:80%;height:auto;">[vc_video link="https://youtu.be/FTYAQLC1IWY" align="center"]</div>

    @mburke79

    I would try different combinations of using the video shortcode and the video URL along with both size options and see what happens.

    Let us know if that helps.

    Also, start/stop video when popup opens/closes.

    • This reply was modified 5 years, 10 months ago by waltmesser.
    Plugin Author Daniel Iser

    (@danieliser)

    @mburke79 – Just took a look, do you currently have just the youtube link for your popups content? Or are you using a theme shortcode at the moment in that test.

    The reason I ask is that their is a couple wrapper divs from your theme, so if you pasted just the youtube link then they are filtering and adding it somehow.

    In any case they seem to be resizing the iframe using JavaScript, the problem is they do this when they page first loads, your popup & iframe are hidden at that point which makes their height & width = 0 so it doesn’t work properly.

    You can likely fix it with some CSS or by removing the wrapper and just embedding the video without it.

    If your currently using the theme shortcode to show it, please update to just use the built in WP version so I can take another look.

    Hope that helps.

    Thread Starter mburke79

    (@mburke79)

    @danieliser @waltmesser

    Thank you for the responses.

    I have narrowed this down to a theme issue, but I haven’t resolved it yet. Here are the steps I’ve taken so far.

    1. In the Pop-up Content Editor, I have ONLY the youtube link:
    https://youtu.be/FTYAQLC1IWY

    2. I activated theme “TwentySixteen” and everything worked normally

    3. I activated theme “XStore Child” and again the same issue. I tried to see a CSS solution using developer tools but I didn’t get far.

    So thats where it stands right now. Only the YouTube URL in the Pop-up content editor.

    @mburke79

    Did you try this

    <div style="width:400px;height:300px;">https://youtu.be/FTYAQLC1IWY</div>

    and/or this

    <div style="width:100%;height:auto;">https://youtu.be/FTYAQLC1IWY</div>

    in the Popup Editor?

    • This reply was modified 5 years, 10 months ago by waltmesser.
    Thread Starter mburke79

    (@mburke79)

    Just tried it – its a no go. I left it so you can see.

    @mburke79

    Ok, I’ll see what @danieliser idea was.

    Plugin Author Daniel Iser

    (@danieliser)

    @mburke79 – I believe this was solved via email support. Closing this for now.

    Thread Starter mburke79

    (@mburke79)

    @danieliser
    Perhaps you’re confusing me with someone else? I didn’t receive any email support. I’m happy to take this conversation to email tho…

    Point me in the right direction!

    Plugin Author Daniel Iser

    (@danieliser)

    @mburke79 – Last I looked your theme was modifying the default output of WP for youtube embeds adding a wrapper to them. You need to go to the video in question though and simply copy the url in the address bar to put into the popup, for instance when I visit the youtube link above it goes to: https://www.youtube.com/watch?v=FTYAQLC1IWY

    Paste that into the popup as the only content and lets see what happens. I know I solved the CSS for this previously not sure why the solution didn’t get posted. Probably because we were trying to get it to not render the extra wrapper.

    Might also be worth checking with your themes support to see if there is a quick simple way to remove that function from the theme using a filter or something.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Embed YouTube Video’ is closed to new replies.