WordPress.org

Support

Support » How-To and Troubleshooting » Embed YouTube and Not show related video's when video is finished

Embed YouTube and Not show related video's when video is finished

Viewing 15 replies - 1 through 15 (of 30 total)
  • It’s not ?rel=0… it’s &rel=0

    Note you were using a question mark. It should be an ampersand.

    Hi Josh,

    I am going by YouTube’s new code now

    <iframe width=”560″ height=”315″ src=”http://www.youtube.com/embed/Y0V8Mlr2ANY?rel=0″ frameborder=”0″ allowfullscreen></iframe>

    if you look at it now

    it is ?rel=0

    I tried the &rel=0

    as you recommended but the video now wouldn’t play

    here I left it up for you to see

    http://knssconsulting.com.previewdns.com/?p=367

    Hi I have exactly the same problem and have tried the same solutions as above with the same results.
    Would love to know the solution…

    @knssconsulting,

    Here is the iframe code you are using:

    <iframe width="960" height="500" frameborder="0" allowfullscreen="" src="http://www.youtube.com/embed/?autoplay=0&loop=0&wmode=opaque&title=" marginwidth="0" marginheight="0"></iframe>

    Try this instead:

    <iframe width="960" height="500" frameborder="0" allowfullscreen="" src="http://www.youtube.com/embed/?rel=0&autoplay=0&loop=0&wmode=opaque" marginwidth="0" marginheight="0"></iframe>

    Hi Josh,

    I tried posting your code and nothing happened.

    I don’t think I am using an iframe

    Here is the code from what I can find from the video

    [videoembed type=”youtube” align=”aligncenter” width=”960″ height=”500″ url=”http://www.youtube.com/watch?v=Y0V8Mlr2ANY&rel=0” id=”video-0″]

    Hi Neil,

    Yeah for some reason WordPress and the theme developers have not made it easy to work with YouTube and their coding.

    Let me know if you find anything Neil

    I thought you were inserting this via HTML.

    What button are you using to insert the video?

    Try switching to the html view and try my code above again. Just to see if it works.

    Hi Josh,

    I did copy the code below of mine from the HTML view

    [videoembed type=”youtube” align=”aligncenter” width=”960″ height=”500″ url=”http://www.youtube.com/watch?v=Y0V8Mlr2ANY&rel=0″ id=”video-0″]

    As well I copied and pasted your code above in the HTML editor and saved it

    <iframe width=”960″ height=”500″ frameborder=”0″ allowfullscreen=”” src=”http://www.youtube.com/embed/?rel=0&autoplay=0&loop=0&wmode=opaque” marginwidth=”0″ marginheight=”0″></iframe>

    Here is the link so you can see

    http://knssconsulting.com.previewdns.com/?p=367

    Hi Josh,

    any luck?

    This is really frustrating, I am searching all over for a solution still no luck.

    I was hoping the WordPress Support Team would chime in and maybe they know a fix?

    The only thing i am able to do at the moment is put a pause on the end of the video but that is not really a fix.

    A trick I learned, which I didn’t really want to do is, you leave a splash screen at the end with your logo and how to contact you at the end of the video. let it run for 5 seconds or so. So people think the video’s is down and stops there.

    It is a really bad work around but that is one way of doing it.

    Hopefully a WordPress happy engineer chimes in. But I think these issues are Theme specific because my wordpress.com works fine. I copied the code from there and not it doesn’t work which makes me think it’s the way the theme’s have been coded.

    What do you think?

    I am using themeforest 533913 Corona Business Portfolio Theme. Which theme are you using? From what your saying I would agree this does seem to be theme specific.
    Lets hope someone can help us.

    I am using Tersus from Theme forrest, it’s a great Theme a few bugs. but I’m loving the options.

    I agree hopefully someone can help us a as well. Especially because of Youtube

Viewing 15 replies - 1 through 15 (of 30 total)
  • The topic ‘Embed YouTube and Not show related video's when video is finished’ is closed to new replies.