Support » Fixing WordPress » Embed html codes disappear on publishing

  • Hello,

    Within the past few days I’ve been experiencing problems with my embed codes. I insert them via HTML into my post as per usual, click preview, note that everything’s fine, schedule and save the post. I’ve even gone to check and I can see that all scheduled posts still include their embed codes. But then WHAM, as soon as it goes live the whole embed code disappears from both the Editor view and the post itself. It’s like someone’s gone into my posts and deleted the HTML.

    It’s really frustrating as I embed into most posts and schedule all. Basically it means there’s no point in scheduling now as I’m having to go back into every post to correct the HTML anyway. When I re-embed, the code remains where it is and everything publishes fine.

    Anyone got any ideas what’s up?

    Besides some mandatory WP updates I’ve not installed any new and possibly conflicting Plugins. I’ve cleared my cache. The only other topics I can find on this issue all involve conflicting Plugins…

    Tiff

    The blog I need help with is http://www.drunkenwerewolf.com.

Viewing 4 replies - 1 through 4 (of 4 total)
  • esmi

    (@esmi)

    Forum Moderator

    Sorry but this is a known issue in WordPress 3.5. see http://core.trac.wordpress.org/ticket/22944

    Until a fix is issued, avoid using <iframe> and <script> markup in scheduled posts.

    At least it’s not me! Thanks x

    Hi, this is still an issue for me but the core.trac page says it’s been fixed??

    Bump – any help? The link above says the issue’s been fixed but it hasn’t been from my end. I’ve tried reinstalling the update – is there a patch somewhere that I’m missing or are we just glossing over this issue and hoping it’ll go away?

    It’s really affecting my site stats – people come to the site to listen to music and at the moment they can’t do that until I re-edit a post.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Embed html codes disappear on publishing’ is closed to new replies.