Support » How-To and Troubleshooting » Embed code disappears (for some users) in WordPress 2.7

Embed code disappears (for some users) in WordPress 2.7

  • I have a blog with multiple authors, and since I upgraded from 2.7 from 2.3 a few weeks ago, my contributing authors are unable to embed videos into their posts. When they click “Publish” or “Save Draft”, the embed code DISAPPEARS. It is completely stripped from the post.

    This happens with video code from any source (YouTube, Metacafe, Dailymotion, Break.com — you name it.)

    The funny thing is that I, as the Admin user, am able to post videos or other embedded content just fine.

    All of my other contributors have “Author” permissions. This happens whether or not the “Disable Visual Editor” box is clicked in the user settings.

    Anyone have any ideas or suggestions?

Viewing 15 replies - 1 through 15 (of 24 total)
  • Nobody?

    I am having the same issue. If any one can shed some light on it, it would be very helpful.

    I recall seeing a post about this last week, I think. An answer provided by one of the mods was to the affect that only admins have the ability to embed – no other rank can. Might want to do a search and see if you can find the exact post.

    I have the same problem. Admin can embed just fine, Authors not so much.

    Here is a link to the WP.com forum where a work-around is shown.
    Not as nice as the embed, but close. Basically inserting the url using the media tool.


    There are other similar instructions for the other video sites.

    Here’s the thing about that though. You only get a link to the YouTube, not a actually embedded video like the solution tells you.

    Also, the additional info below their instruction (use: [youtube=http://www.youtube.com/watch?v=H2Ncxw1xfck] )
    Doesn’t work. You will only get the text of that.

    I know its not much, but hopefully someone else will come along with a real solution.

    I say AGAIN … only those with admin access can embed files. AUTHOR is not an admin level position.

    I have administrator access. Whenever I try to embed video from youtube I go to html view, use the tag, then paste right in the embed video from youtube, then use . If I then immediately save and leave, all is good. If I edit any more in the post, or go back in and edit something later, wordpress changes the code and removes the embed statements and leaves just the object code. After this the video no longer shows up on my mac under Firefox, although I see it is still visible on a windows PC. This is extremely frustrating having to battle WP every time I want to do something to simple as embed a video from youtube. I guess it is naive of me to think that the tag means "don't mess with this at all", but that is surely what I want. I read another thread that suggested the object only code is in some way better. After WP has "fixed" my code (by breaking it) and removed the embed statements, should the video still be showing on all machines? (and why can't I see it). I tried using the Add Media tool using the instructions at http://support.wordpress.com/videos/youtube/ and it only inserts a link to the video, does not embed video in the post as the instructions say it will.
    There are lots of different threads around here on users struggling with various problems with this very basic blogging function of embedding a youtube video. I have been battling it for many versions now and 2.7.1 still doesn't have it right. Solving this issue would mean a lot more to many users, I think, than a complete makeover of the interface. -please pardon my frustration

    I don’t understand why only Admins can post a YouTube video. That’s ridiculous. My blog has almost a dozen authors and I want them all to be able to post YouTube videos, but I don’t want to give them all Admin authority to do that.

    YouTube videos are content, and that’s what authors do: post content. I shouldn’t have to give every Author the ability to change the blog’s design and settings just so they can show a dog dressed up as Thor.

    If this is really an official restriction and not a glitch, why doesn’t it specify “You must have Admin authority” on all of the help pages where it explains how to post a YouTube video?

    I’m not saying you guys are wrong that authors aren’t able to post videos. What I want to know is why, and where does it officially say that?

    This ticks me off, because I just did a huge post on my site about how to paste in YouTube code, only to have my authors replying that it doesn’t work for them. That’s pretty embarrassing.


    This is pretty irritating. We’re using WP-MU and have the same issue, but it seems like all levels of user are unable to paste the embed code in.

    We even imported an xml file of a WP site we’re moving and all them embed codes were stripped out!

    I am an admin and I still can’t embed objects into posts…

    I have the same problem with a wordpress mu 2.7.1 installation. No user (including admin) on any of the blogs (including the default) can save objects in posts.

    After saving a post with an “object” copied from youtube, the contents of the post disappear. Help?

    This works for me. I am admin on my blog – I haven’t tried it as a user. Blog is version 2.7.1.

    Basically, I’m pasting the Embed code on the HTML tab and then going back to visual mode. It does not molest the embeded code – I’ve also saved the post and gone back to it, edited it and saved it again to see if that was a problem and it was not.

    @oakshorn: This doesn’t seem to work with non-admin users.

    I am an admin and I cant embed a video file either so thats not the problem

    This is the same in 2.8.

    Same for me. I’m an admin. It’s hit and miss for me. Sometimes it strips the entire code, sometimes it strips part of the code, sometimes it works just fine I’m using 2.8.3, but this happened when I was using 2.7 as well.

    Help please gangsters

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘Embed code disappears (for some users) in WordPress 2.7’ is closed to new replies.