Support » Themes and Templates » Embarrassed but my parent theme is not found!

  • I am trying to create a child theme for the Smart One. I have followed directions TO THE LETTER. I know I have successfully done this in the past but now, no matter what theme I try to create the child for, it says the theme is broken and I need to install the parent theme.

    I can see the parent theme on my server and I have copied and pasted it into the style.css for the child. My template is smartone and my directory name for the theme is smartone. So what is the problem? I tried deleting everything and reinstalling my theme, creating the child theme area anew but it made no difference.

    I’m embarrassed to even ask this but I can’t see what I’m doing wrong. Suggestions? Thank you,

Viewing 15 replies - 1 through 15 (of 15 total)
  • post child theme‚Äôs style.css at Please use

    also post ls listing of themes folder

    It will be a small typing error

    Here it is on pastebin:

    I still can’t see the problem.

    Here is the header block from your Parent Theme’s style.css:

    Theme Name: SmartOne
    Theme URI:
    Description: Simple yet elegant and smart. Besides easy readability and clean design with a shadow effect, the SmartOne comes with up to 9 navigation menu color schemes, custom header (12 preinstalled elegant headers) and background which guarantee unlimited color variants. Other features are 4 customizable subscribe buttons, custom sidebar, content font styles and your own CSS styles. Custom menu, six widgetized areas and the admin Visual Editor are standard. Cross-browser compatible (including IE since 6.0).
    Author: Theme4Press
    Author URI:
    Version: 1.0.5
    Tags: blue, silver, light, white, two-columns, translation-ready, fixed-width, custom-menu, custom-colors, custom-header, custom-background, theme-options, threaded-comments, sticky-post, microformats, rtl-language-support, editor-style
    License: GNU General Public License v2.0
    License URI:

    Is the Template name case-sensitive? If so, that is your problem. Compare the parent:

    Theme Name: SmartOne

    vs. the child:

    Template: smartone

    Try changing smartone to SmartOne, and see if that fixes your problem?

    I tried changing “smartone” to “SmartOne” but it gives the same error, that I need to install the SmartOne/ theme. I notice very error always has that slash after the template name and I don’t know if that is an indicator of something.

    I had thought the template name was the same as the directory for the theme. I’ve tried changing the directory name to something else and I can see in my Manage Theme area that the directory name is updated under the theme. But it doesn’t seem to matter what I put in the for the template name; it is not being recognized from the style.css for the child theme.

    I also tried including the entire path for the directory in the template name and for the import line but those didn’t work either.

    I can’t believe I have spent so much time on this and that I cannot see what the problem is. What else can I try?

    Possibly dumb question, but: is the SmartOne Theme properly installed? The directory is there, but has its style.css been changed at all?

    Also: I wouldn’t ever change the subdirectory names for the Themes. If possible, change them back to their default. (A lot of Plugins and even Theme functions depend on knowing the names of these directories.)

    I haven’t changed style.css for Smart One at all.

    I did put the directory name back and have also tried deleting and reinstalling the theme. It installs without error and I can activate it with no problem. There should not be anything wrong with the parent theme. I feel like it must be something in the child style.css but I don’t know what since I copied/pasted from the WordPress Codex. I wish I could be happy with the theme as is but I really would prefer to make some edits to it.

    Any other ideas? I would love nothing more than to find I have made a stupid error in public here because then I could fix it and be productive. Thank you!

    Okay, a longshot idea: change the name of your Child Theme, from “smartone-child” to “My Child Theme” (or something). Do you get any different results?

    Here is how I have my child theme set up. This is at the top of the style sheet.
    You don’t have the template name listed in yours as I do. I think that makes a difference

    Theme Name: Oak Grove Plantation
    Theme URI: http: //
    Description: Oak Grove Plantation Site 2011
    Author: Oak Grove Plantation
    Template: oakgrove
    Version: 1.0

    And one more thing I just noticed in your pastebin: what is the “style.css” file that is in the wp-content\themes\ root directory?

    @innkeeperea: she does have the Template tag. Here’s her style.css header block:

    Theme Name: smartone-child
    Theme URI:
    Description: Child Theme for Smart One
    Author URI:
    Template: smartone
    Version: 1.0.2

    I saw that extra style.css in the themes root directory…that must have gotten copied there by accident. I took it out but it made no difference. I renamed my child theme to smarty-pants-child but I still get the error:

    Broken Themes

    The following themes are installed but incomplete. Themes must have a stylesheet and a template.
    Name Description
    Smarty Pants Child\ The parent theme is missing. Please install the “smartone\” parent theme.

    I am going to go C-R-A-Z-Y. I created a child theme for a different wordpress site back in December and it works fine. I copied the style.css from that one and updated the names as appropriate but it still cannot find the parent for this site. I feel like the problem must be somewhere other than my style.css.

    Is there a debugger that would show me where WordPress is looking for my parent theme? I appreciate everyone’s attempts to help me figure this out. I was a little worried no one would respond at all because questions like this usually have a quick and easy fix.

    By chance, do you have a redirection plugin, or something in your .htaccess file, that is adding the trailing slash?

    I don’t believe that should be there, and I can’t see anything in your Parent Theme style.css or your Child Theme style.css that would be adding it.

    I don’t know where that trailing slash is coming from, I don’t have that at the other web site. I will check my plugins and htaccess to see what might be happening there. Thank you for this suggestion. Will post back later.

    I fixed it but I don’t know exactly what did it.

    I compared plugins across my 2 sites and found one that might have been a problem. I deactivated it (hope I didn’t mess up anything elsewhere on the site…can’t remember if I had ended up reallyneeding that one). But it didn’t fix my problem.

    I compared the .htaccess files across my 2 sites and the one for the problem site was missing a line that the other site had so I copied it over. That didn’t seem to fix my problem.

    I deleted the child directory and recreated it. I recreated my style.css file by copying the contents of the one from the parent, updating the name and adding the template tag. I swear I tried this before to no avail. I don’t know what is different but it works now.

    I better go back up everything. Thank you all for your help!

    Just wanted to chime in – I had this problem, and it turned out that the capitalization was different on the parent theme folder name from what I had in the child style.css

    So capitalization apparently matters, check all that stuff first.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Embarrassed but my parent theme is not found!’ is closed to new replies.