Support » Plugin: Subscribe To Comments Reloaded » Emails showing HTML

  • Resolved Bodhipaksa

    (@haecceity)


    A subscriber just sent me a screenshot from his phone of the “Please confirm your subscription” email. It was displaying all the HTML as text, making the email difficult to read. Any ideas?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author WPKube

    (@wpkube)

    Hi,

    What is his email provider ( GMail, YahooMail… I’m assuming not one of those )? Will create an account to test it out.

    • This reply was modified 9 months, 1 week ago by WPKube.

    Thanks. He has a Gmail account.

    Plugin Author WPKube

    (@wpkube)

    Oh, that’s weird. Can you send over the website URL, I’ll subscribe and test it out.

    Sure. The post that the problem notification came from was this one: https://www.wildmind.org/blogs/on-practice/a-new-direction-for-wildmind

    Plugin Author WPKube

    (@wpkube)

    Hi,

    Yeah, I’m getting the same thing, tried 2 of the posts.

    In WP Admin > StCR > Options, there’s an option called “Enable HTML” emails is that disabled or enabled? And regardless of what is is at the moment, can you try switching it to the other option and testing (or let me know when you switch and I’ll test).

    Bodhipaksa

    (@haecceity)

    It was set to “no” so I’ve changed it to “yes.”

    Please do go ahead and test it again. Thank you!

    Plugin Author WPKube

    (@wpkube)

    Hi,

    It does improve it quite a lot but there are a couple issues in there.

    Head over to WP Admin > StCR > Notifications. What is the text in the “Double Check Message” options. Should be like this:

    You have requested to be notified every time a new comment is added to:
    <a href='[post_permalink]'>[post_permalink]</a>
    
    Please confirm your request by clicking on this link:
    <a href='[confirm_link]'>[confirm_link]</a>
    Bodhipaksa

    (@haecceity)

    Thank you! That field was rather messed up:

    You have requested to be notified every time a new comment is added to:
    <a href="<a href="[post_permalink]">[post_permalink]</a>"><a href="[post_permalink]">[post_permalink]</a></a>
    
    Please confirm your request by clicking on this link:
    <a href="<a href="[confirm_link]">[confirm_link]</a>"><a href="[confirm_link]">[confirm_link]</a></a>

    I’ve changed to it match what you posted about. The Management Page message text was also messed up, and I’ve fixed that too. One more test wouldn’t do any harm, though!

    Plugin Author WPKube

    (@wpkube)

    Hi,

    Yeah, tested it and it displays correctly now.

    Bodhipaksa

    (@haecceity)

    Thank you. I very much appreciate your help.

    Plugin Author WPKube

    (@wpkube)

    You’re welcome.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Emails showing HTML’ is closed to new replies.