Support » Plugin: Front End Users » Emails not working from Register Form or Forgotten Password.

Viewing 15 replies - 1 through 15 (of 16 total)
  • this link will take you to where the login for is etc…

    http://www.boltonabbey.tig.me.uk/image-library-login/

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Have you made sure to fill out all the fields in the emails tab?

    Yes, have filled all fields in, and tried with and without SMTP.

    Nothing is being generated by the forms.

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    Are you getting any error messages?

    Is the email you are sending from xxx@boltonabbey.tig.me.uk?

    Not that it’s strictly required, but your domain has no MX record:

    ;boltonabbey.tig.me.uk.		IN	MX

    You have an SPF record:

    boltonabbey.tig.me.uk.	14400	IN	TXT	"v=spf1 +a +mx +ip4:46.102.194.132 ~all"

    You said you setup SMTP – was your public-facing outbound SMTP server 46.102.194.132?

    If can’t answer yes to both these questions then you can’t rule out a delivery issue.

    Hi Guys, ok register form is now working, removed smtp setting and (my bad!) realised i had the top field on the email settings filled in incorrectly – once this was addressed the register form started to work.

    however – the forgot password form is still not sending out emails.

    Also I didn’t realise that the admin of the site doesn’t get an email when someones registers! could this be included in an update? it is needed for this excellent plugin to function professionally.

    Many Thanks Rich.

    hi guys here is the error log when using the forgot password:

    [02-Apr-2015 12:00:36 UTC] PHP Notice: Undefined variable: ewd_feup_user_fields_table_name in /home/gfhfgyhui/public_html/boltonabbey/wp-content/plugins/front-end-only-users/Functions/Process_Front_End_Forms.php on line 94
    [02-Apr-2015 12:00:36 UTC] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘WHERE Field_Value = ‘0’ AND Field_Name = ‘Email” at line 1 for query SELECT * FROM WHERE Field_Value = ‘0’ AND Field_Name = ‘Email’ made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), call_user_func_array, Process_EWD_FEUP_Front_End_Forms, Forgot_Password
    [02-Apr-2015 12:00:36 UTC] PHP Notice: Trying to get property of non-object in /home/gfhfgyhui/public_html/boltonabbey/wp-content/plugins/front-end-only-users/Functions/Process_Front_End_Forms.php on line 95
    [02-Apr-2015 12:00:36 UTC] PHP Notice: Trying to get property of non-object in /home/gfhfgyhui/public_html/boltonabbey/wp-content/plugins/front-end-only-users/Functions/Process_Front_End_Forms.php on line 96
    [02-Apr-2015 12:00:37 UTC] PHP Notice: Undefined variable: Salt in /home/gfhfgyhui/public_html/boltonabbey/wp-content/plugins/front-end-only-users/Shortcodes/Insert_Forgot_Password.php on line 36
    [02-Apr-2015 12:00:37 UTC] PHP Notice: Undefined variable: Time in /home/gfhfgyhui/public_html/boltonabbey/wp-content/plugins/front-end-only-users/Shortcodes/Insert_Forgot_Password.php on line 36
    [02-Apr-2015 12:00:37 UTC] PHP Notice: Undefined variable: Time in /home/gfhfgyhui/public_html/boltonabbey/wp-content/plugins/front-end-only-users/Shortcodes/Insert_Forgot_Password.php on line 37

    You need to post this in the Troubleshooting forum.

    [02-Apr-2015 12:00:36 UTC] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE Field_Value = '0' AND Field_Name = 'Email'' at line 1 for query SELECT * FROM WHERE Field_Value = '0' AND Field_Name = 'Email' made by require('wp-blog-header.php'), require_once('wp-load.php'), require_once('wp-config.php'), require_once('wp-settings.php'), do_action('init'), call_user_func_array, Process_EWD_FEUP_Front_End_Forms, Forgot_Password

    There shouldn’t be two quotes after Email. Looks like one or more of your core WordPress files is mangled.

    HI,

    just installed wordpress on a fresh test site using basic theme – and have only the front-end users plugin and still get the same syntax error!

    see here:
    [02-Apr-2015 12:59:08 UTC] PHP Notice: Undefined index: User_ID in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Functions/Prepare_Data_For_Insertion.php on line 37
    [02-Apr-2015 12:59:08 UTC] PHP Notice: Trying to get property of non-object in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Functions/Prepare_Data_For_Insertion.php on line 84
    [02-Apr-2015 12:59:08 UTC] PHP Notice: Undefined variable: CatalogueCatalogue_Name in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/html/LevelsPage.php on line 29
    [02-Apr-2015 12:59:08 UTC] PHP Notice: Undefined property: stdClass::$Level_Item_ID in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/html/LevelsPage.php on line 56
    [02-Apr-2015 12:59:34 UTC] PHP Notice: Undefined variable: CatalogueCatalogue_Name in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/html/LevelsPage.php on line 29
    [02-Apr-2015 12:59:34 UTC] PHP Notice: Undefined property: stdClass::$Level_Item_ID in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/html/LevelsPage.php on line 56
    [02-Apr-2015 12:59:44 UTC] PHP Notice: Undefined variable: CatalogueCatalogue_Name in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/html/LevelsPage.php on line 29
    [02-Apr-2015 12:59:44 UTC] PHP Notice: Undefined property: stdClass::$Level_Item_ID in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/html/LevelsPage.php on line 56
    [02-Apr-2015 13:05:37 UTC] PHP Notice: Undefined variable: Salt in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Shortcodes/Insert_Forgot_Password.php on line 36
    [02-Apr-2015 13:05:37 UTC] PHP Notice: Undefined variable: Time in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Shortcodes/Insert_Forgot_Password.php on line 36
    [02-Apr-2015 13:05:37 UTC] PHP Notice: Undefined variable: Time in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Shortcodes/Insert_Forgot_Password.php on line 37
    [02-Apr-2015 13:06:33 UTC] PHP Notice: Undefined variable: ewd_feup_user_fields_table_name in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Functions/Process_Front_End_Forms.php on line 94
    [02-Apr-2015 13:06:33 UTC] WordPress database error You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘WHERE Field_Value = ‘0’ AND Field_Name = ”’ at line 1 for query SELECT * FROM WHERE Field_Value = ‘0’ AND Field_Name = ” made by require(‘wp-blog-header.php’), require_once(‘wp-load.php’), require_once(‘wp-config.php’), require_once(‘wp-settings.php’), do_action(‘init’), call_user_func_array, Process_EWD_FEUP_Front_End_Forms, Forgot_Password
    [02-Apr-2015 13:06:33 UTC] PHP Notice: Trying to get property of non-object in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Functions/Process_Front_End_Forms.php on line 95
    [02-Apr-2015 13:06:33 UTC] PHP Notice: Trying to get property of non-object in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Functions/Process_Front_End_Forms.php on line 96
    [02-Apr-2015 13:06:33 UTC] PHP Notice: Undefined variable: Salt in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Shortcodes/Insert_Forgot_Password.php on line 36
    [02-Apr-2015 13:06:33 UTC] PHP Notice: Undefined variable: Time in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Shortcodes/Insert_Forgot_Password.php on line 36
    [02-Apr-2015 13:06:33 UTC] PHP Notice: Undefined variable: Time in /home/rhujhnbg/public_html/website-test/wp-content/plugins/front-end-only-users/Shortcodes/Insert_Forgot_Password.php on line 37

    Hi guys, this is the error log from an absolute fresh install, with the plugin activated but not being used ;

    [02-Apr-2015 14:38:00 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/gfhfgyhui/public_html/boltonabbey/wp-includes/functions.php on line 3495
    [02-Apr-2015 14:38:00 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/gfhfgyhui/public_html/boltonabbey/wp-includes/functions.php on line 3495
    [02-Apr-2015 14:38:00 UTC] PHP Notice: Undefined variable: CatalogueCatalogue_Name in /home/gfhfgyhui/public_html/boltonabbey/wp-content/plugins/front-end-only-users/html/LevelsPage.php on line 29
    [02-Apr-2015 14:38:00 UTC] PHP Notice: Undefined property: stdClass::$Level_Item_ID in /home/gfhfgyhui/public_html/boltonabbey/wp-content/plugins/front-end-only-users/html/LevelsPage.php on line 56
    [02-Apr-2015 14:38:16 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/gfhfgyhui/public_html/boltonabbey/wp-includes/functions.php on line 3495
    [02-Apr-2015 14:38:16 UTC] PHP Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/gfhfgyhui/public_html/boltonabbey/wp-includes/functions.php on line 3495

    its seem s to be having some issues – any help out there?
    Richard.

    You can ignore any line that starts with PHP Notice. But you can’t ignore the line that start with WordPress Database Error.

    Plugin Contributor EtoileWebDesign

    (@etoilewebdesign)

    We’re planning on putting out an update to resolve this next week, let us know if that doesn’t solve the problem!

    Sorry guys used another plugin ages ago, WP-Memebers with worked perfectly out the box.

    Hope you get the plugin functioning as it should, take a look at the above mentioned plugin because this really does tick all the boxes.

    Many Thanks.

    Hi TRGRichie,

    A bit late… Were you using permalinks with postname? The emails wont get send because the URL starts with &add=… instead of ?add=…

    You can fix this in /Functions/Process_Front_End_Forms.php on line 135
    Hope this fixes your issue.

    Greetings,
    Ferhat

    Hello, the forgot password email is not working. Any help?

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Emails not working from Register Form or Forgotten Password.’ is closed to new replies.