Support » Plugins and Hacks » [Resolved] Emails not translated completely (Italian)

[Resolved] Emails not translated completely (Italian)

  • Hi everyone,

    I’ve noticed that in some emails (specifically the one thanking the client for the order), some strings are not translated. I checked out the .po file in the plugin’s directory and everything seems translated. I’ve also translated everything that’s available in my child theme.

    Is it Woocommerce that’s missing stuff or my theme?


Viewing 4 replies - 1 through 4 (of 4 total)
  • Here’s a screenshot for reference: http://screencast.com/t/yvebId2qK

    I checked out the string in the .po file and it’s perfectly translated. So I suppose that it’s a Woocommerce bug.

    Plugin Author James Koster


    Only thing I can think to suggest is that the .mo file hasn’t been generated?

    As you can see this string is definitely localised;

    _e( "Your order has been received and is now being processed. Your order details are shown below for your reference:", 'woocommerce' );

    I can see that and it is translated in the po file. I regenerated the .mo for good measure and uploaded to my site but still the same. No theme template is involved (removed) so it’s definitely something in the WooCommerce code. Does everything work normally in your test installations for languages?

    Sorry, my client messed with the email templates and I did not know that. No bug whatsoever.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] Emails not translated completely (Italian)’ is closed to new replies.