Support » Plugins and Hacks » WP eCommerce » Emails not sending

Emails not sending

  • I’m using WP e-Commerce v3.8.11.1 & WP E-Commerce shop styling v1.9.2. Emails were sending fine. But after several test checkouts (using manual/test gateway) to check the look for the emails, the emails stopped sending to customer and I don’t receive the admin transaction reports either.

    Tried to clear purchase logs from database, but it still doesn’t send out. Anyone knows why??


Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author Justin Sainton


    If you click the “Resend Email to Buyer” link on the single purchase log page – does that send the email?

    I did. It didn’t send too. When you change the status to accepted payment, it’s supposed to send a payment completed email to the customer. Now, it doesn’t too.

    I cleared cookies and all, then tried to checkout using another new email address. This time, the ‘customer’ received the email. But the admin transaction report was not received.

    No solution? I’m getting lots of complaints because of this error.

    Plugin Author Justin Sainton


    More than happy to help debug – but I have not been able to replicate this issue to date. There have been a very small handful of people who have reported it, but it’s obviously an issue. If there is anything unique about your server configuration or site – that could be helpful.

    What information do you require?

    Did you figure this out?


    I am also having the same problem. I tried all version of WPEC from 3.8.X until the latest, and I am using latest WP 3.5.1. All plugins are turned off. During Sandbox and Live testing, everything is going through and transactions are converting to “Acceptable Payment”, but email notification to buyer and admin is not happening.

    Any help would be highly appreciated.

    Plugin Author Justin Sainton


    Can you confirm that WordPress is sending emails properly? You can do this by triggering an email via user registration, password reset, etc.

    same problem. (WPEC
    WP sends emails correctly (password recovery etc.).

    What I found out is that the email is okej once sent out of the gmail mouth. Google took it as spam.. because it recognizes the server from which the email is being send as another domain.

    this might be a solution (in the case that emails ends up in the Gmail spam)
    add to your dns this:
    TXT ‘v=spf1 include:_spf.google.com a:DOMAIN-NAME-OF-THE-ACTUAL-SERVER.COM ~all’

    This seems to be caused by the payment gateway… try changing that to test & confirm. This is the issue I’m having at the moment as well using the Moneris gateway. See https://code.google.com/p/wp-e-commerce/issues/detail?id=1319#c7

    I am having this issue as well. Have tried the test gateway as well as the custom gateway neither trigger a customer email but both trigger the admin email.

    I have tried every solution I have found including downgrading the plugin, clearing the purchase_log table, and adding code to the transaction results function for the specific gateway. WordPress is obviously triggering emails because I receive the admin emails with no issue.

    I am running WordPress 3.5.1 and WP e-Commerce with a custom gateway provided by the client.

    Any help would be greatly appreciated.

    Disable the gateway and test again. If it works without the custom gateway, then that’s the issue – it will need to be patched to resolve.

    That’s the thing giving me trouble – I tried it with the default test gateway and the custom gateway and neither send a customer email.

    Did you *disable* the custom gateway? You can just disable the plugin, but it does need to be disabled to confirm. Which gateway does it use?

    It uses Trident Gateway as far as I can see – just tired disabling gateway completely and I am still getting the same result with the default Test Gateway

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Emails not sending’ is closed to new replies.
Skip to toolbar