Support » Plugin: Jetpack by » Emails not sending

Viewing 15 replies - 1 through 15 (of 38 total)
  • How come it takes so long for a response? This post is 2 days old…

    I have the same problem — subscribers were being emailed of new posts and it was working fine, but latest post not sent. I’m a little frustrated as this is the third time this has happened and I’ve done nothing to change anything in the interim.


    Plugin Contributor Jeremy Herve


    @catinthefridge Could you post your site URL here, so I can have a look?

    If you want it to remain private, you can also contact us via this contact form:

    @louiseallan I checked our email logs for a few of your subscribers, and it seems that they all received a notification email about your latest post, on May 14 at 06:02 UTC. If some of your subscribers did not receive the email, could you send me their email address via this form, so I can have a look at our logs?

    Jeremy, It did not initially send the emails to subscribers when I published the posts. I had to revert to Draft and Publish again and the second time, they sent. This has happened with the last two posts. Why is this happening?

    Also, it is not automatically sending the notification to Twitter.

    I’m having a similar problem. The post I published today doesn’t seem to have gone out to email subscribers. I check this by subscribing with my own email, and I haven’t received anything, so I assume others haven’t either.

    My url is:

    I’ve done a similar thing to louise. Returned the post to draft status, republished it, and the emails were sent.

    Plugin Contributor Jeremy Herve


    I checked both sites, and your Jetpack connection seems to be working properly.

    Do you use any plugins that may affect the status of your posts, or copy / clone existing posts?

    Could you both walk me through the steps you followed to publish your last post?

    Thank you!

    Hi there, sorry was out of town! The issue spontaneously resolved itself 2 days after I posted here, and worked fine for a week. This morning, my new scheduled post did not go out via email again. My URL is

    Oh! same thing. I reverted to draft, published again, and the emails got sent. Strange….

    Plugin Contributor Jeremy Herve


    Could you all try to publish a new post, and let me know if the problem happens again?


    Same problem for me.

    Posts were working fine last week, now emails are not sending out (I’m subscribed).

    I went back to draft and then re-published and it sent out the email. Very frustrating.

    While we’re on the subject of Jetpack and new post emails – why is it still not possible to send just an extract of the article? I want people to read my posts on the website, not in their email – where they also format terribly. Can we expect this functionality soon?

    I have noticed something that might be useful, Jeremy: My last post sent emails to subscribers the first time I published it. The only difference between that one and the others, was that I uploaded it on the day I published it. I still revised it many times before publishing, but I uploaded it that day. It seems that anything that I upload and save as a Draft for a day or two before I publish, does not get emailed to subscribers when I publish, but once I save it as a Draft again and republish it gets sent. I’m looking forward to hearing the solution.

    By the way, none of my posts are ever sent straight to Twitter. I’m having to do that manually each time. Do you cover that, or do I need to post that problem elsewhere?

    Oh, and one more thing: I, too, would like to be able to send an extract only to email subscribers and not the whole post. Just something else to think about…

    In response to Louise, I created my post on the same day as publishing. Publishing as soon as I’d finished writing it. I still had the problem…

    Same problem here.

    2 out of 4 posts published in the last two weeks have not sent out email notifications to subscribers.

    Extremely frustrating, and we’re doing nothing out of the ordinary on our end. Write post -> publish -> random or no emails to subscribers.

    Edited to add: Also reverted latest post to draft and then republished. Took two times doing it (waiting a few minutes apart each time) for the email to go through. Second time I changed the original posting time. Not sure if that was the difference maker, but still frustrating that things aren’t working as expected.

    Plugin Contributor Richard Archambault


    Happiness Engineer


    I think the issue may have to do with a mismatch with your siteurl and homeurl settings. Can you let me know what you have in your “WordPress Address (URL)” and “Site Address (URL)” boxes, in Settings -> General?


    Hmm, everything seems fine with your site. Would you happen to have the email address of someone who definitely did not get your post by email? I can check on our end. Please send it to and link to this thread; don’t post it here. 🙂


    same with you, everything seems fine on your site. Can you do the same as I asked from sterumbelow? As for sending only an excerpt of your post by email, you can do so if you include the Read More tag. Only what’s before the tag will be sent by email. Note that this may change how posts are displayed on your site, depending on the theme.

Viewing 15 replies - 1 through 15 (of 38 total)
  • The topic ‘Emails not sending’ is closed to new replies.