Support » Plugin: Subscribr » Emails not sending

  • So, after working and finding a workaround the php mail system an sending out a successful email, subscribr is no longer sending notifications. I have sent a test email through the plugin. I have even made sure emails are being sent out. Both scheduled and non scheduled posts are not sending out updates.

    https://wordpress.org/plugins/subscribr/

Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Author Mindshare Labs, Inc.

    (@mindshare)

    Can you detail step by step how to reproduce this issue?

    Thread Starter DylangerBravo

    (@dylangerbravo)

    I write a post.

    I select the categories that email addresses are subscribed to receive updates about.

    I publish the post.

    None of the subscribed emails receive a notice of the new post.

    Plugin Author Mindshare Labs, Inc.

    (@mindshare)

    That’s not super helpful… obviously under normal circumstances the mail gets sent when you follow those steps.

    We need to know exactly *what is unique about your setup* that is preventing the mail delivery. If you can’t provide more info we can’t really debug it for you.

    Thread Starter DylangerBravo

    (@dylangerbravo)

    Ok, I’ll try to explain what I have going on:

    I am running the most current version of WordPress on HostGator using Portfolio press and all plugins, themes, etc. are up to date.

    I was using the Subscribe2 plugin to send notifications but didn’t like it’s functionality, so I switched to your plugin. Subscribe2 is still installed but deactivated.

    I am using WP_Members to restrict access to some content on the site. If someone does not have an account, they cannot follow the link emailed to them as it will give them a denied access message and prompt a login. When I ran my last test run that worked, I sent it as “unblocked” as it was a general message saying our system was running again.

    I have used the “check email” plugin to test that emails are being sent and received properly, which resulted in a successful test. (it is still active)

    I am also running WP missed schedule to help run regular backups as our traffic is a bit low at the moment, but I imagine this would help with any email cron jobs.

    I also have WP SMTP running which enables me to bypass the wordpress email engine and instead send from our outlook365 server from a specified email address created for the website.

    the last successful email was sent 6/23/15 and I confirmed it went out by talking to recipients and even getting some email bouncebacks to the outlook email account saying some email addresses weren’t entered correctly into user profiles.

    please let me know if you need anything more specific. Thanks a lot for your help!

    Plugin Author Mindshare Labs, Inc.

    (@mindshare)

    Hi great info.

    1. Can you quickly disable WP SMTP and test to see if the notifications work again?

    2. Can you tell me what hooks you are using to trigger notification in the plugin settings?

    Thread Starter DylangerBravo

    (@dylangerbravo)

    new_to_publish,pending_to_publish,auto-draft_to_publish,draft_to_publish,future_to_publish

    I deactivated WP SMTP and sent another post but I have not yet received it. I waited a good 10-15 minutes

    Plugin Author Mindshare Labs, Inc.

    (@mindshare)

    Very weird. This might not be possible but can you try deactivating all plugins and switch to the default theme and then testing again? that will narrow it down to a theme or plugin specific issues and rule out a host/server problem.

    Thread Starter DylangerBravo

    (@dylangerbravo)

    i did that and got the update about 30 minutes later.

    Plugin Author Mindshare Labs, Inc.

    (@mindshare)

    Next I would try just using the default theme and reactivate all your plugins. If it works then we know to look for the issues in the theme. If it doesn’t work we need to through each active plugin until we determine which one is causing the conflict by activating one at a time and testing again until we figure out which plugin is breaking things. Most likely its one that has to do with cron, caching, or mail.

    Thread Starter DylangerBravo

    (@dylangerbravo)

    ok. I am reactivating one plugin at a time and sending test emails. I will let you know tomorrow what I find. Thanks!

    Thread Starter DylangerBravo

    (@dylangerbravo)

    So, I reactivated each plugin one at a time and sent out a test post that way. My yahoo address received each post. My exchange server email addresses only received the ones after i reactivated WP SMTP. This is a similar problem to the one I had that made me start using WP SMTP. It appears to be working again, but I don’t understand why it wasn’t before. Could a plugin need to be “reset” through deactivation and reactivation?

    Plugin Author Mindshare Labs, Inc.

    (@mindshare)

    I am not sure… it sounds like maybe the exchange server is blocking the other messages – maybe they are getting sent and stopped by an automated filter or spam trap but not when using SMTP?

    Plugin Author Mindshare Labs, Inc.

    (@mindshare)

    That reply was meant for another thread… oops

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Emails not sending’ is closed to new replies.