WordPress.org

Support

Support » Plugins and Hacks » SendPress Newsletters » emails not sending

emails not sending

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author itdoug

    @itdoug

    Start here and let me know what the results are. Also, many hosts block email but this article should help you figure out if they are.

    http://sendpress.com/support/knowledgebase/troubleshooting-sending-email/

    i did what you said ant i get this on the test email

    Port 25 seems to be blocked.
    Port 465 seems to be blocked. Gmail may have trouble
    Port 587 seems to be blocked.
    Could not instantiate mail function.
    Could not instantiate mail function.

    Plugin Author itdoug

    @itdoug

    You’ll need to contact your host. If you need gmail have them open 465. If sending from your server have them open 25.

    My host opened 465 & 587 and I’m still have gmail issues. I can send from the host without any problem, but my they are on many block lists for doing exactly what I want to do; send mail to multiple recipients.

    Plugin Author itdoug

    @itdoug

    Sounds like you need to use a bulk email sender, like sendgrid. Our pro version can send through them and several others. Sendgrid specifically allows sending through their API so ports can never be blocked.

    It’s not making any sense. I’ve had a gmail account for years which I mostly access via Thunderbird on a Linux OS. My host and WP installation is on a Linux server.

    There’s nothing on my computer that’s blocking anything, and my ISP doesn’t block mail ports.

    I tried a couple of other WP smtp plugins and none were able to connect to gmail, or any other server I tried, as I have access to 4 in total, the only successful one being my host.

    Plugin Author itdoug

    @itdoug

    Does sendpress show your ports as open?

    I had issues once where ports were open but the firewall was blocking smtp separately. I was using config server firewall. You have to enable smtp even though smtp ports are open.

    Mine say ports are blocked but they aren’t. My shared host provider Just host blocks sites from using SMTP. It would be great in the settings if we had the option to send using PHP mail() or SMTP as I can send using my Gmail if I use PHP mail()

    To see the option select between choosing PHP Mail() and SMTP mail look at the the plugin WP-Mail SMTP (http://wordpress.org/plugins/wp-mail-smtp/), this is was this plugin needs.

    On the settings > sending account. I chose send via emails via your website and it worked and seems to have used my gmail account.

    Itdoug – Does this mean is using the PHP mail() function? If so then this is the work around for this thread.

    Install the plugin WP-Mail-SMTP put your smtp mail provider settings in there and make sure you select use PHP mail() to send emails (NOT SMTP). Then in SendMail choose send emails from your website. Emails should now be able to bypass your hosts firewall.

    Plugin Author itdoug

    @itdoug

    Sounds like a great workaround! I’ll check out that plugin too. Maybe I ca. Write up a KB article if I can confirm it works.

    Thanks – I tested if from SendPress and it worked perfectly, with the Sender being my Gmail account.

    FYI – I’m running 3.5.1, and the plugin is compatible, despite the warning.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘emails not sending’ is closed to new replies.
Skip to toolbar