WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Emails not sending

[Resolved] Emails not sending

  • Emanuel Sferios
    Member

    @emanuel-sferios

    I set up an admin user on my site with an email address on my domain and made that the “from” email.

    I set up a “thank you for subscribing” page and used the “id” paramater to direct new subscribers to that page. The page says, “please check your email to confirm your subscription, yada yada yada.” It works fine.

    I ran tests but no email was sent. I installed “Email Log” plugin and there is nothing in the log.

    What should I do now?

    Thanks!
    Emanuel

    http://wordpress.org/plugins/subscribe2/

Viewing 15 replies - 1 through 15 (of 33 total)
  • Emanuel Sferios
    Member

    @emanuel-sferios

    Oh and just to clarify, I installed Email Log and then ran some test subscriptions to see if the emails were being sent. And they aren’t, or at least they are not appearing in the email logs.

    mattyrob
    Participant

    @mattyrob

    @emanuel,

    If you go to Subscribe2->Send Email and attempt to send an email from there do you get any error message and does the email appear in the log?

    Emanuel Sferios
    Member

    @emanuel-sferios

    Yes. That works.

    Emanuel Sferios
    Member

    @emanuel-sferios

    And yes it appears in the log.

    mattyrob
    Participant

    @mattyrob

    @emanuel,

    Have you. Got excluded categories in the Subscribe2-> Settings page?

    Emanuel Sferios
    Member

    @emanuel-sferios

    Yes I do. Is that the problem?

    Emanuel Sferios
    Member

    @emanuel-sferios

    We never use those categories for new posts. They are only placeholder categories for specific sections of the website that were created a long time ago.

    Emanuel Sferios
    Member

    @emanuel-sferios

    Well I just tried it without any excluded categories and it still did not work. 🙁

    Germont
    Participant

    @alergic

    What plugin do you use for sending mails ?

    mattyrob
    Participant

    @mattyrob

    @emanuel,

    If you exclude a category and then assign a post to that category (even if it is in other categories) the post is suppressed as it’s in an excluded category.

    You should perhaps also check that the ‘Don’t send email’ button on the authoring page is not checked by default in the settings also.

    @alergic,
    We are discussing the Subscribe2 plugin.

    Germont
    Participant

    @alergic

    I just wanted to say that I use WP-Mail SMTP. I couldn’t make Subscribe2 working until I installed something like that. Or maybe it could be working without it ? Sorry if I am wrong !

    mattyrob
    Participant

    @mattyrob

    @alergic,

    You are quite right. With email limitations on many hosting servers these days it is often better to push emails through an authenticated SMTP server.

    Emanuel Sferios
    Member

    @emanuel-sferios

    @mattyrob, I’m not sure you have understood. It’s not the category exclusion. Not even the subscriber confirmation emails are being sent. Only the “Send Email” button actually works. None of the automated email functions work.

    Why would I need to install a mail plugin? All my normal WP emails are working fine. It’s just subscribe2 that is not working.

    mattyrob
    Participant

    @mattyrob

    @emanuel,

    It might be worth trying SMTP to exclude a mail() function on the server though. Emails for things like comments and registrations are single emails. Subscribe2 produces many emails.

    Also have a check for plugin and the conflicts. Disable all other plugins and reverts to a core theme and test again to see if that works.

    Emanuel Sferios
    Member

    @emanuel-sferios

    I’ll check for a plugin conflict, but assuming that’s not the problem, are you suggesting this plugin?

    http://wordpress.org/plugins/wp-smtp/

    This seems to be complicating things more than it has to.

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Resolved] Emails not sending’ is closed to new replies.