• Emails are not sending natively through host, they are not sending through native SMTP settings in MailPoet (Mandrill), and they are not sending through PostSMTP (Mandrill). Every other email on my site sends fine. Emails do not even show in the mail log of PostSMTP or in Mandrill.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Contributor MailPoet

    (@mailpoet)

    Hi @wpnzach

    Sorry, it’s not clear which emails are you referring to when you said “Emails are not sending natively through host”: WordPress transactional emails or MailPoet newsletters?

    How’s your MailPoet set up to send transactional emails? https://kb.mailpoet.com/article/292-choose-how-to-send-your-wordpress-websites-emails

    Also, which plugins are affected?

    Thanks in advance.

    I assumed since this is a support forum for Mailpoet, that would be clear.

    It’s Mailpoet emails which are not sending. The effected plugin is Mailpoet. All other emails from all other plugins are working properly.

    I listed the ways I have tried to configure MailPoet in my original comment.

    • This reply was modified 1 month, 2 weeks ago by Zach Skaggs.
    Plugin Contributor MailPoet

    (@mailpoet)

    Sorry @wpnzach, that wasn’t clear. MailPoet can now send transactional emails as well ( https://kb.mailpoet.com/article/292-choose-how-to-send-your-wordpress-websites-emails ) so we needed to clarify what exactly did you mean by “emails”. Newsletters or transactional emails.

    Emails are not sending natively through host,

    – It seems you tried to set up MailPoet to send emails (newsletters/transactional) using your own host (PHPMail option) and that didn’t work. Okay, that could be a PHP Mail related-issue.

    they are not sending through native SMTP settings in MailPoet (Mandrill),

    – I assumed here you set up MailPoet to send newsletters/transactional emails using Mandrill with an SMTP connection. Are you sure your connection details are correct? Is your host SMTP ports open?

    and they are not sending through PostSMTP (Mandrill).

    – So your Mandrill SMTP connection details it’s not even working It seems the SMTP Ports are blocked on your server: https://kb.mailpoet.com/article/179-smtp-ports-bocked-by-host

    Every other email on my site sends fine.

    – using PHPMail (wp_mail) or SMTP?

    Emails do not even show in the mail log of PostSMTP or in Mandrill.

    – MailPoet newsletters or transactional emails?

    Yes, I am sure that my SMTP setup is correct…every other plugin sends fine through it…it should hijack all wp_mail calls by default, except it’s own log does not show any attempts from MailPoet newletters.

    When I configure MailPoet to use the Mandrill SMTP correctly instead of using the other SMTP plugin, it still does not actually send any emails. The logs in MailPoet say that mail was sent, but there are no logs showing the message in Mandrill. MailPoet is saying it’s sending messages, but nothing, in fact, is sending.

    SMTP ports are not blocked on my server, as again, Mandrill works find to send these from every other WordPress plugin via wp_mail (served by my SMTP plugin).

    The issue is not PHP mail. The issue is not SMTP ports blocked on my server. The issue is very specifically something in MailPoet not playing nicely.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.